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am writing this editorial the day

after returning from the MAX 2004

Macromedia Conference in New

Orleans, LA. As a veteran (or sur-

vivor) of many conferences, I can honest-

ly say that this was one of the finest

events I have ever attended.

In the October issue of this journal, I

put forth the opinion that the future of

this business is Flash. This conference

more than supported that theory with

one slight amendment: Flash inside of

mobile technology.

Over the next few months, we will be

reporting about the issues and products

presented at this year’s MAX.

The first day’s General Session

brought forth many interesting facts. But

the big news was that over the next five

years, mobile Flash development will be

an $80-billion industry. At present, more

than 23 million mobile handsets are

equipped with the Macromedia Flash Lite

player to deliver Web services seamlessly

with a rich Internet interface.

Because Macromedia is so committed

to this market, a new support program

was introduced at MAX called the Mobile

Developer Program. It will support

mobile developers by offering marketing

assistance, information pooling, direct

access to a support team, and access to

testing servers.

For more information about this excit-

ing program, please visit www.macrome-

dia.com/devnet/devices/dev_program.

Over the next year, you will be seeing

more articles about this rapidly growing

technology.

If the audience was not “wowed”

enough with that news, Macromedia

introduced Flex 1.5. What I found espe-

cially exciting about this was the intro-

duction of Flex Builder. This gives Flex a

Dreamweaver-like development interface

(and then some). Further, like the other

Macromedia server technologies, a free

developer’s edition is now available for

download at www.macromedia.com/soft-

ware/flex/trial.

The General Session also brought

an incredible demonstration –

Blackstone, the newest version of

ColdFusion. November 2 was the U.S.

election day. The audience was asked

to deliver a text message, from their

cell phones, to a designated address.

The text message had to be 1 for John

Kerry, 2 for George Bush, or 3 for Ralph

Nader. As the audience did this, we saw

Blackstone tabulate the results and

deliver a moving bar chart. Ben Forta

subsequently showed Blackstone’s

capability to, once again, work with the

mobile market.

Of course, the real purpose of the

conference was the workshops. While it

was physically impossible to attend every

event, I would like to mention several

that I got to see (and please do not inter-

pret this as my saying that others were

not as good).

Ben Forta did a wonderful hands-on

ColdFusion workshop. Of course, one can

never say anything bad about Ben’s talks

and workshops.

His workshop focused on the impor-

tance of structuring code properly for

reusability, efficiency, and maintenance. I

sensed many members of the audience

walked away with a new understanding

of code development.

What I found interesting, however,

was his defense of ColdFusion not

becoming more object oriented. His feel-

ing is that the purpose of ColdFusion was

to combine power with simplicity; and

adding OOP capability increases com-

plexity. After seeing the demonstration at

the earlier General Session, it was tough

to argue the point.

A particular favorite of mine was

Angela C. Buraglia’s workshop called

“Dreamweaver Killer Tips.” Angela has

always amazed me with her insights and

she certainly did not disappoint here. I

am an author of a couple of Dream-

weaver books and a pretty seasoned

user. Yet, even I walked out of her semi-

nar with some new ideas. Happily, Angela

Group Publisher Jeremy Geelan
Art Director Louis F. Cuffari

EDITORIAL BOARD
Editor-in-Chief
Charles E. Brown charles@sys-con.com
Dreamweaver Editor
Dave McFarland
Flash Editor
Brian Eubanks
Fireworks Editor
Joyce J. Evans
FreeHand Editor
Ron Rockwell
Louis F. Cuffari
Director Editor
Andrew Phelps

INTERNATIONAL ADVISORY BOARD
Jens Christian Brynildsen Norway,
David Hurrows UK, Joshua Davis USA,
Jon Gay USA, Craig Goodman USA,
Phillip Kerman USA, Danny Mavromatis USA,
Colin Moock Canada, Jesse Nieminen USA, 
Gary Rosenzweig USA, John Tidwell USA

EDITORIAL
Executive Editor
Gail Schultz, 201 802-3043
gail@sys-con.com

Editors
Jamie Matusow, 201 802-3042
jamie@sys-con.com
Nancy Valentine, 201 802-3044
nancy@sys-con.com

Assistant Editors
Natalie Charters, 201 802-3041
natalie@sys-con.com
Seta Papezian, 201 802-3052
seta@sys-con.com

Technical Editors
Jesse Warden • Sarge Sargent

To submit a proposal for an article, go to
http://grids.sys-con.com/proposal.

Subscriptions
E-mail: subscribe@sys-con.com
U.S. Toll Free: 888 303-5282
International: 201 802-3012
Fax: 201 782-9600
Cover Price U.S. $5.99
U.S. $29.99 (12 issues/1 year)
Canada/Mexico: $49.99/year
International: $59.99/year
Credit Card, U.S. Banks or Money Orders
Back Issues: $12/each

Editorial and Advertising Offices
Postmaster: Send all address changes to:
SYS-CON Media
135 Chestnut Ridge Rd.
Montvale, NJ 07645 

Worldwide Newsstand Distribution
Curtis Circulation Company, New Milford, NJ 

List Rental Information
Kevin Collopy: 845 731-2684,
kevin.collopy@edithroman.com, 
Frank Cipolla: 845 731-3832,
frank.cipolla@epostdirect.com

Promotional Reprints
Kristin Kuhnle, 201 802-3026
kristin@sys-con.com

Copyright © 2004
by SYS-CON Publications, Inc. All rights
reserved. No part of this publication may be
reproduced or transmitted in any form or by any
means, electronic or mechanical, including
photocopy or any information storage and
retrieval system, without written permission. 

MX Developer’s Journal (ISSN#1546-2242) 
is published monthly (12 times a year) by 
SYS-CON Publications, Inc., 135 Chestnut
Ridge Road, Montvale, NJ 07645. 

SYS-CON Media and SYS-CON Publications,
Inc., reserve the right to revise, republish, and
authorize its readers to use the articles submit-
ted for publication. MX and MX-based marks
are trademarks or registered trademarks of
Macromedia, in the United States and other
countries. SYS-CON Publications, Inc., is inde-
pendent of Macromedia. All brand and product
names used on these pages are trade names,
service marks or trademarks of their respective
companies.

fro
m

 th
e

 e
d

ito
ri

The face of the future
by charles e. brown

The Afterglow of 
2004

Charles E. Brown is the

editor-in-chief of MX

Developer’s Journal. He is

the author of Fireworks

MX From Zero to Hero

and  Beginning

Dreamweaver MX. He

also contributed to The

Macromedia Studio MX

Bible.  Charles  is a senior

trainer for FMC on the MX

product family.



has agreed to contribute some articles to

this journal in the future.

Our own Art Phillips delivered a won-

derful seminar on the very topic he is

writing about in these pages: rapid appli-

cation development in Flash using

dynamic data. Art is one of those rare

individuals who can take a confusing and

complex topic and reduce it to a few sim-

ple and understandable steps. Further, he

does it without losing the power and

possibilities behind the technology. I was

quite happy to see the enthusiastic

reception he received afterwards.

Here is an interesting statistic: most

HTML Web sites, including Amazon.com,

have less than 3% of their visitors actual-

ly completing a transaction. However,

Flash sites could go as high as 8%. This

year, we saw a lot of seminars on how to

use Flash for online sales. One of the best

seminars on this topic, “Single-Screen

Checkout: Next Generation Solutions

using Flex,” was delivered by Praveen

Ramanathan.

Praveen is with a company called

Molecular, Inc., which has developed sev-

eral commercially available RIA shopping

carts. He gave a very convincing argu-

ment, using a couple of case studies, that

RIA is the way to go for online commerce.

By having all the information in one

place, the potential customer does not

need to move back and forth between

screens.

The exhibitor area showed us a lot of

new and exciting products. Over the next

few months, we will be reviewing many

of them on these pages. A very special

thank you needs to be mentioned here.

If you are a regular visitor to our Web

site, www.sys-con.com/mxdj, you may

have noticed that we have SYS-CON

Radio. This service provides interviews

with various industry professionals. I was

about to record some interviews right

from the exhibitor’s floor when our

recording equipment stopped function-

ing properly. Our good friends from

InterAKT Online jumped to the rescue

and saved the day with a portable MP3

recorder.

You will see their ads in this journal. 

I am a huge fan of their Dreamweaver

expansion products. However, as a thank

you from the community who reads this

journal, please take a look at their site at

www.interaktonline.com. I think you will

be very impressed.

Finally, another special thank you to

Gail Schultz and Dorothy Gil who worked

long hours at the SYS-CON booth signing

up new subscribers and answering ques-

tions. Thanks to them, there are several

hundred new members to our communi-

ty.

By the time you read this issue, the

holidays will be upon us. I want to take

this opportunity to wish each of our

readers a joyous holiday and a healthy

and happy 2005.

Next month, I’ll be announcing

some exciting changes coming to this

journal.
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his past year, Macromedia has

experienced incredibly exciting

progress and growth in its mobile

and devices strategy, and attendees at

MAX 2004 were the first to catch a glimpse

of what the future has in store for the

Macromedia Flash community. On Mobile

Day at MAX, developers had the exclusive

chance to hear from Macromedia, wireless

industry leaders, and fellow developers

about how to work together to create

compelling mobile content – and no one

is better positioned to help drive the

direction and meet the growing demand

for engaging content for mobile devices

than Macromedia and the Flash developer

community. To help content owners and

Flash developers make the most of the

opportunities in this brave new mobile

world, Macromedia has introduced the

Mobile Developer Program (www.macro-

media.com/devnet/devices/dev_pro-

gram).

A Fast-Growing Market for
Flash Developers

The goal of the Mobile Developer

Program is to pull developers into the

growing momentum of Flash in the

mobile phone industry. In 2003, Japan’s

largest operator, NTT DoCoMo, was the

first to adopt Macromedia Flash Lite.

Since then, 10 more operators have

adopted Flash Lite for their mobile offer-

ings, including KDDI, T-Mobile, and 8 i-

mode global operators – and the number

of companies interested in incorporating

Flash Lite into new phones continues to

grow. With more than 23 million Flash-

enabled handsets in the hands of con-

sumers, and many millions more to ship

in the coming years, there is a very strong

and ever-growing market waiting for the

Macromedia developer community.

The reasons why Flash Lite is quickly

becoming the platform of choice for

handset manufacturers and operators

who want to provide rich interactive

mobile content are not surprising. By

supporting rich user interfaces and ren-

dering engaging content that consumers

demand, Flash Lite makes it easy for orig-

inal equipment manufacturers (OEMs) to

build and customize user interfaces, and

for operators to differentiate their con-

tent and service offerings. Also, Flash is

the standard for creating rich interactive

content; every major Web site uses it, and

brand holders are eager to port their

existing content to the mobile platform.

With more than 1 million seasoned Flash

developers on hand, whose experiences

creating rich user interfaces, games, ani-

mation, and applications of all types are

instantly applicable to the mobile phone

market, OEMs and operators know that

the Flash community has the bandwidth

and know-how to meet the fast-growing

demand for compelling mobile content.

If you’re a developer or content

owner, or if you’re looking for opportuni-

ties to create new content or extend the

revenue opportunities of existing content

or entertainment brands, look no further.

Unlike the Web, where users are less will-

ing to pay for content and businesses

often give content and services away for

free – often as an extension of their mar-

keting and public relations efforts and

without counting upon an immediate

return on their investments – the mobile

space is populated by millions of users

who have come to accept that they must

pay for mobile content, including games

and other content services. In the pay-as-

you-connect mobile world, the continu-

ing improvements in the speed and capa-

bilities of mobile networks will bring a

new brand of mobile applications to mil-

lions of wireless users and communities.

Looking ahead, Don Harris, CEO of

AirMedia (www.airmedia-inc.com), a

developer and publisher of mobile appli-

cations for leading brand holders and a

charter member of the Mobile Developer

Program, anticipates “a multibillion-dollar

revenue opportunity to create and deliv-

er engaging mobile entertainment appli-

cations that will deliver a user experience

unlike any other to date.”

A Program Developers Can
Count On

The goal of the Mobile Developer

Program is to facilitate the creation of con-

tent for mobile phones and assist devel-

opers around the world in building mobile

content businesses. More specifically, the

program is designed to open the fast-

growing global mobile community for

Flash developers, help developers around

the world to market their products better,

and accelerate the global deployment of

Flash content for mobile devices. To that

end, the program currently offers the fol-

lowing benefits to participants:

• Developer services and support: The

Mobile Developer Program offers the

range of technical benefits and services

that developers need to create content

for Flash-enabled mobile devices.

Program members get access to a wealth

of useful resources – including basic

development tools and a large library of

quick-start guides, technical information,

tips, and tutorials – that build on and

extend existing Macromedia Developer

Center resources, as well as expert devel-

oper support, training, and development

assistance.

• Marketing assistance: To help develop-

ers and content owners find new ways

to cultivate business opportunities and

potentially monetize their efforts,

Macromedia will provide co-marketing

support for qualified program partici-

pants. This support includes an online

showcase produced by Macromedia

that features new content and applica-

tions for the mobile platform. Featured

products may be included in press and

analyst awareness programs, and

Macromedia can facilitate and coordi-

nate the participation of featured devel-

opers in key industry events, including

sponsored speaking opportunities.

• Information sharing: Timely knowl-

edge of new possibilities is crucial for

the development of optimal solutions.

To ensure that developers are always

plugged into what’s happening in the

Macromedia Unveils New Mobile
Developer Program

Meeting a growing market
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mobile space and to facilitate an

ongoing dialog between Macromedia,

developers, content owners, and oper-

ators around the world, the Mobile

Developer Program team will keep

developers informed about upcoming

events such as trade shows, confer-

ences, seminars, contests, and more

with electronic newsletters.

• Direct access to Macromedia:

Program members will have direct

access to the Macromedia Mobile &

Devices team. Through this access

members will have a unique opportu-

nity to help shape the current devel-

opment and future direction of Mobile

& Devices products.

• Business support: As part of the

Mobile Developer Program,

Macromedia will work closely with

operators, developers, and content

owners around the world to build a

broad ecosystem for mobile content.

Macromedia will initiate business dis-

cussions for the distribution of content

to mobile phones and introduce

Mobile Developer Program partici-

pants and partners to business oppor-

tunities that will help both developers

and publishers expand their business-

es. While Macromedia secures distribu-

tion and monetization opportunities

for the Flash mobile community, devel-

opers can focus on creating and deliv-

ering compelling mobile experiences.

Showcase Opportunity:
Make a Name for Yourself

As part of the new Mobile Developer

Program, Macromedia has launched the

program’s first annual Flash Lite Content

Contest (www.macromedia.com

/mobile/special/contest). The contest

provides developers with the unique

opportunity to showcase their innovative

work as well as a chance to be among

the first participants in the program to

gain recognition within the mobile com-

munity and monetize their efforts. Using

the Flash Lite content development kit

(CDK), program participants can submit

entries in the following categories: Most

Innovative Use of Flash Lite, Best Game,

Best Interactive Content, Best

Educational Content, Best Business

Application, Best Productivity

Application, Best Animation, and Best

Overall Use of Flash Lite.

The grand prize winner will be

rewarded with a 42-inch flat-screen TV,

and first-place winners in each category

will receive a 20GB Apple iPod. In addi-

tion, all winners will be showcased on

mobile.macromedia.com. Those with the

most promising content will be intro-

duced to operators for a chance to dis-

tribute their compelling content and

potentially generate revenue opportuni-

ties. 

Get with the Program
Don’t miss out on the exciting new

opportunities in this mobile space.

Operators and OEMs count on the Flash

community to meet the fast-growing

demand for mobile applications that

engage, entertain, and inform from any

location and at any time. Take advantage

of the new Mobile Developer Program,

which has been designed to meet the

unique needs of the Flash community,

and to succeed in the lucrative mobile

phone market. You can register at

mobile.macromedia.com for this free

program. Registration provides access to

the Flash Lite CDK and regular communi-

cations from Macromedia, including the

Mobile Developer Program team’s future

monthly developer newsletter and tar-

geted developer e-mails.

At mobile.macromedia.com you will

also be able to pre-register for the much-

anticipated FlashCast CDK (previewed at

Mobile Day at MAX 2004), which enables

developers to build push-type informa-

tion services and interactive applications

that are bound to revolutionize the

mobile consumer space. The Mobile

Developer Program team will notify you

as soon as it is available.

References
To get started with Flash Lite, check

out the following links:

• Macromedia Flash Lite 1.1 Developer

Center: www.macromedia.com/

devnet/devices/flashlite.html

• Evans, Troy. “Introducing Macromedia

Flash Lite 1.1”: www.macromedia.com/

devnet/logged_in/tevans_flashlite

.html

• Perry, Bill. “Best Practices for Developing

Macromedia Flash Lite 1.1 Content”:

www.macromedia.com/devnet/devices

/articles/flashlite_bestpractices.

html



lash ActionScript has come a long

way since Flash 5. However, never

has the leap been as great as with

the release of Flash MX 2004. 

This is the first in an open-ended

series of articles explaining ActionScript

2.0 right from the beginning. In this

series, I will be presenting concepts and

simple tutorials to help you understand

this powerful new programming environ-

ment.

What’s New with
ActionScript 2.0

First of all, let me begin by saying that

ActionScript 1.0 will work in Flash MX

2004. However, I don’t recommend this.

At some point, the practices of Action-

Script 1.0 will probably no longer be rec-

ognized. As we progress through this

series you will see why.

ActionScript 2.0 is a full-fledged

object-oriented program, or OOP, very

close to the Java programming language.

This means that it does things very differ-

ently from ActionScript 1.0 and that your

coding must be more precise and effi-

cient. As anyone who has programmed in

Java will tell you, it is very unforgiving.

But, the end result is better running pro-

grams. The real benefit, however, is code

that will run up to 7 times faster than

code in AS 1.0.

One of the first differences you will

encounter is that AS 2.0 is case sensitive.

As an example, if you create a variable

called:

firstName

it will be different from:

FirstName

Because of this, most OOP programmers

have adopted the following naming stan-

dards:

• No spaces

• Begin with a letter and NOT a number

• Everything is in lower case except for

mid-word capitalization (as in firstName

above).

There are some exceptions that we

will see as we progress through these

articles. I will point them out as we go

along.

A Flash statement should end with a

semicolon. In programming parlance this

is called the line terminator. Once again,

this is in keeping with OOP standards.

Data Typing
A data type tells a variable what it can

and cannot do. For instance, you could

not take two variables of type String and

try to total them. The variable type String

simply does not know how to perform

arithmetic operations.

AS 1.0 did not require data typing.

You could do something like this:

myAge = 23;

Flash would just make assumptions

and plug in what it thought was the cor-

rect data type. This often led to data mis-

matches and error-prone code. However,

in AS 2.0 you would need to use the fol-

lowing syntax:

var myAge:Number = 23;

Notice that I began with the keyword

var to indicate that I was declaring a vari-

able. I then named the variable using the

naming conventions discussed above;

finally, I typed a colon and the data type

(Note: data types begin with a capital let-

ter. There is a reason for this, which we

will learn later). 

While this may sound like an added

nuisance, strict data typing will give you

more efficient running code with fewer

possibilities for error.

The Development
Environment

Begin by opening the Actions Panel. I

have sometimes also heard it referred to

as the ActionScript Editor.

The upper left corner is the Action

toolbox. This is a quick way to harness

many of the components available to you

in ActionScript. It is organized into cate-

gories to ease locating an element. We

will discuss this more as we move along.

The lower left corner is the Script

Navigator. This will assist you in finding

where your various scripts are located. As
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a result, you can get to your scripts quick-

ly and easily.

Right above the main editing area is

the Script Pane Toolbar. This contains

some tools that can be used to assist you

in creating and editing scripts. As we

progress through these articles, you will

become very familiar with this panel.

Object-Oriented
Programming Concepts

Before we begin, there are some basic

concepts that need to be understood

and that are common to all OOP pro-

grams.

The basic unit of programming is

called the class. Basically, a class is a file

that contains code that does a special-

ized job. In Flash, the class file has the file

extension of .as (In Flash, this is created

using the File > New > ActionScript File

menu option).

In most cases, you do not use the

class directly. You need to copy it into

memory where it is called an object (thus,

object-oriented programming). We call

this process instantiation (we are creating

an instance of the class).

Since the object is located some-

where in memory, we need a way to find

and reference it. The object is referenced

by using a special variable called the

Instance Name (Note: most object-orient-

ed programs call this the object refer-

ence).

As an example, let’s say we have a

class file called Date (by tradition, the

name of the class file begins with a capi-

tal letter. This is why the data types are

named that way). We would create an

instance of it as follows:

var thisDate:Date = new Date( );

If we dissected this line, var means

that we are creating a new variable. The

variable name, thisDate, will be the vari-

able or instance name.

Here is where things get a bit interest-

ing. Earlier, I said that the data type tells

the variable what it can or cannot do.

Since the class file will give the instance

name its marching orders (the class file

we will be using, in this case Date, follows

the variable name and a colon), the class

file is now the data type. In OOP terms,

we sometimes refer to the class as the

user-defined name.

The keyword new instructs

ActionScript to create the object. The

final part, Date( ), refers to something

called the constructor, which we will dis-

cuss at a future point. Place any parame-

ters the object may need to do its job

inside of the parenthesis.

As we progress through these articles,

we will revisit the concept of creating

objects many times.

Now we need to look at what the

object contains and how it helps us. 

If you examine an existing project,

the objects (or the class files the

objects are based upon) are the nouns

of that project. As an example, suppose

that you wanted to build a Flash proj-

ect that would allow users to design

their own cars. Some of the objects

would be tires, windows, steering

wheel, etc. 

Each of the objects contains three

basic components: properties, methods,

and events. 

For instance, the seat objects in the

car could have the properties of color,

material, etc. So we can think of the prop-

erties as the adjectives of the object.

These would be the variables inside of

the class file.

The process of the seats adjusting

would be the methods. Again, using the

parts of speech analogy, the methods

would be the verbs. These are the meth-

ods in the class file.

Finally, what makes the seats adjust?

In many cars it is pressing a button or

moving a lever. This would be the event

causing the action to happen and would

be handled by an Event Listener. The

Listener is a bit of code that listens for the

event to happen (such as a mouse click,

pressing a key, data being loaded, etc.)

and then triggers the correct code to run

(Event Handler). 

Let’s assume we created a class file

called AutoSeats that had two properties:

material and color. We would instantiate

it as follows:

var mySeats:AutoSeats = new AutoSeats

(leather, red);

We could create as many AutoSeat

objects as we need.

Later on, if we needed to obtain the

information from the object, we would

use something that looks like this:

mySeats.property;

In OOP, we call this dot syntax. On the

left side of the dot is the name of the

object and on the right side of the dot is

the property or method you need to call.

Making Our Lives Simpler
How does all of this help make our

lives simpler?

OOP makes our lives as programmers

simpler in several ways. First of all, class

files are reusable. As an example, sup-

pose you have a class file that converts

any number into currency format. This

class file can be used by any project at

any time. You don’t need to reinvent the

wheel each time you need to do some-

thing. As you progress, you will build up

libraries of class files to do a variety of

jobs.

Second, most object-oriented devel-

opment environments come with a num-

ber of class files built in and ready to go.

As an example, if you look in the Action

Toolbox you will see that each category is

expandable (see Figure 2).

If you expand the built-in classes cat-

egory, drill down to Core, then drill down

further to String, you can see the proper-

ties and methods associated with the

String Class. If you look around, you will

see classes in many other categories. As

we progress through these articles, we

will be examining many of these various

classes.

Third, there are class files available

from both commercial and noncommer-

cial sources. A quick perusal of the

Macromedia Developer’s Exchange will

give you many examples of what is avail-

able. A particular favorite of mine is 

www.flashcomponents.com.

For a fee of about $100 a year, you

have thousands of components available

for download. (A component is a class file

associated with the interface. We will be

discussing them in greater detail in a

future article.)

Flash MX 2004 goes one step further

to make our lives easier. The user inter-

face classes, or components, can be

instantiated without programming by

simply dragging them onto the stage and

giving them a name. We can see this by

returning to the stage and opening the

Components Panel (Flash Professional

contains additional components for han-



dling data). 

For example, suppose we drag the

ComboBox component onto the stage. In

the property inspector, give it an Instance

Name (using the naming standards dis-

cussed earlier).

New to MX 2004, the property inspec-

tor has a tab called Parameters. If you

select that and double click on Labels,

you will see what Figure 3 is showing.

Just type in a list of some sort, pressing

the + key after each entry. After clicking

OK, run a test of the movie. When you

click on the drop arrow for the com-

bobox, it should open with the values

you entered as shown in Figure 4.

This serves to illustrate everything we

just discussed and to show how easily

Flash makes things run. 

The ComboBox class comes built into

Flash and ready to run. If it didn’t, you

would have to build it from scratch. It has

a property called Fields that we were able

to populate (an Array) using the property

inspector. The drop arrow is a button and

an Event Listener triggers the method to

expand the box and display the labels.

If Flash did not have the built-in capa-

bilities, you would have had to go into

ActionScript and type something like

this:

var comboList:ComboBox = new

ComboBox(blue, red, black)

The result is that you have now been

saved from programming several thou-

sand lines of code. This saves you an end-

less amount of time and allows you to

turn projects around much quicker.

Let’s try a very simple ActionScript

that interacts with a UI component.

Open a new Flash document and cre-

ate two layers called component and

script.

On the component layer, drag a

TextArea component to the stage and

give it an Instance Name of taMessage

(Note: as you go through succeeding arti-

cles, you will see that giving an Instance

Name an identifying preface will have

some unexpected benefits. In this case

“ta” means TextArea). 

It is always advisable to place scripts

in their own layers or, as you will see, in

their own files. Script placement can be a

complicated subject and will be dis-

cussed in subsequent articles.

Go to the script layer and open the

Actions panel. Type in the following line

of script.

taMessage.text = “This is my first

ActionScript”;

We used dot notation to access the

text property of the TextArea. 

Run the movie. You should see your

text in the TextArea of your movie. While

this is a very simple example, I am sure

you can see how it could be applied to

more complex situations.

Take a look at the Script Navigator.

You should see two sets of information in

it as shown in Figure 5.

The upper section shows you where

you are now (current selection). The bot-

tom part shows the various locations

where script is located. This makes it

much easier to find code that may be in

various locations.

Let’s try one last simple example

using the exercise we just tried. With the

existing project open, select File > New >

ActionScript File.

Cut the line of code from the script

layer of our project and paste it into the

new ActionScript file. Save the file with a

name, say Test.as (ActionScript files have

an extension of .as).

In the script layer where the code was

originally located, type the following

code:

#Include Test.as

Note that there is no colon at the

end. Run the movie now. It should work

in exactly the same way. We can now

see that it is easy to put our program-

ming code in separate class files and

then just include them into our movies.

As a result, we can use this code any-

where that we need it. While it is only

one line of code, imagine if it were 100

or 1,000, lines. It is not hard to see how

this could make our programming lives

a lot easier.

Summary
Next month, we’ll look at program-

ming structures such as loops and deci-

sion statements. Just as a note, we will be

referring to concepts discussed in this

article.

Charles E. Brown is the editor-in-chief of

MX Developer’s Journal. He is the

author of Fireworks MX From Zero to

Hero and Beginning Dreamweaver MX.

He also contributed to The Macromedia

Studio MX Bible. Charles is a senior

trainer for FMC on the MX product fami-

ly. charles@sys-con.com
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Quick Review
In the August issue I did my best to project the ease of

basic OOP in Flash with my Beginning OOP in Actionscript

2.0 article. In my closing words I stated, “...you can actually

turn this into a powerful tool by adding dynamic data via

XML, Remoting...” which is exactly what we’re going to do

here. To get a full understanding of some of the concepts

I will use I strongly suggest you read that article because I

will not thoroughly explain things I covered then. Think of

this article as Chapter 2 of a book. Sometimes you have to

go back to Chapter 1 to get a full understanding.

The October article dealt with using OOP in Cold-

Fusion in the same way I would in Flash, which was a reve-

lation for me. One of the best learning tools I utilize is

comparing one language to another. I’m very strong in

Actionscript OOP but lacked ColdFusion OOP skills until I

stumbled upon my scopes. I will use three of the same

files for this app but offer minimal explanation.

The source files for both articles are online (www.

jdevinc.com/tutorials). We’re done reviewing and it is time

to get started.

Data Retrieval Setup
The interesting part here is we already have our back

end ready to roll. All we need to do is make a few changes

to the files and we can step into Flash and get to the

good stuff. On every data retrieval project I fight tooth

and nail to use Remoting, especially for database interac-

tion. We are going to take advantage of Flash/ColdFusion

integration via Remoting and show how easy it is to use

existing ColdFusion components with Flash. 

If you recall, we had a data.cfc component. This CFC

had one function, setupAlbums, which was created as an

object in the Application.cfm and stored in the App-

lication scope. We then called the setupAlbums function,

which read our pics directory and created a query of

albums with an embedded query of images (images on

same row as parent album). This query was stored in the

local variable albums. Next, in the Application.cfm we

stored the local variable albums in the Session scope as

Session.albumQ (short for album query). Everything after

that in the Application.cfm is unnecessary since it all per-

tained to an HTML front end. There are a few more edits

as well, and I’ll spit out the lines to delete. Lines 13–18 are

not needed. The <cfif...> block on Line 28 (prior to previ-

ous delete) should be skimmed down to only set up the

Session.albumQ variable; just delete everything after that

and before the closing </cfif> tag. Other than those

changes, the Application.cfm (see Listing 1) is ready to

roll. There is one small addition to the data.cfc compo-

nent.

<cffunction name="getAlbums" access="remote" return-

type="any">

<cfreturn Session.albumQ>

</cffunction>

The code snippet above is the second function in

data.cfc. We will call this function to get the album query;

notice the access attribute is set to remote. This is the

smallest function I have ever written for a Remoting call.

All we are doing is returning the Session.albumQ variable.

This variable is ready and waiting for us to retrieve it since

it is created in the Application.cfm. If you remember, that

file will run before the index.cfm which will hold the

application. 

Our back end is prepped and ready. The only other file

we need to update is index.cfm. All we need to do is strip

all of the contents between the <body> tags and add the

<object> and <embed> tags for Flash. That’s it! We’re now

ready to open Flash. 

A Flash’ing We Will Go
Since we are going to actually have a design on this

app (unlike the August app) I asked Michael Hagel to talk

design stuff since he is the designer of the ColdFusion

photo album showcased in October. Michael is an interface

designer, developer, and inventor. I have worked with him

on several apps, including Central Stream v1, which won

the coveted Site of the Day from Macromedia. Let’s see

what he has to say about the design aspects of this app. 

The Design
Thanks, John! Usually when designing complex inter-

faces for Flash applications or Web sites I start off in an

image editing application (Fireworks, Photoshop, etc.),

then I import the graphics into Flash and lay them out

accordingly. It may not sound like the most productive

way to do things but trust me, on larger projects it will

pay off, both in terms of performance and time. For small-

er apps I usually just stick with Flash’s built-in drawing

tools to design everything. For this application we will use

Flash’s drawing tools to design the UI, then John will con-

tinue with the development of the app.

To start, open Flash and create a new document.

Using the Properties Inspector (Window > Prop-

erties), change the stage size to 700 x 650, leave the back-

ground as white and the frame rate set to 12. We will start

by drawing the main container sections, which will hold

our albums, thumbnails, and large images. 

Open your Tools Panel (Windows > Tools), then select

Layer 1 and choose the Rectangle tool (R) from the Tools

Panel. We want to remove the stroke so in the stroke color

picker select the white box with the red line through it

(see Figure 1).

Change the fill color to dark blue. Let’s break the con-

sistency and use rounded edge rectangles for the UI. Cick

on the Rounded Rectangle Radius button and enter 5 for

the Corner radius setting. Draw a rectangle 165 x 550 and

position it at coordinates (20, 75). This will be our outline

for the album section of the app. Add a new layer (Insert

> Timeline > Layer) and draw another rectangle with a fill

color of white and a stroke of orange. Using the

Properties Inspector, change the stroke weight to 1.5 pix-

els; I usually find anything lower than this – when using a

rounded edge – doesn’t show up enough.



To add some depth to the UI we can

use some of Flash’s shape effects to give it

a shadow and glow. Go back to Layer 1,

copy (Edit > Copy) the blue rectangle, and

create a new layer. Drag the layer under-

neath Layer 1 and Paste in Place (Edit >

Paste in Place). Hide the two layers above

them and you will see the same blue rec-

tangle was pasted directly where it was

copied from – this is a great feature of

Flash and one I wish a lot more graphic

applications had. Now, to soften the

edges on the rectangle, giving more of a

shadow and glow effect, select Modify >

Shape > Soften Fill Edges. Set the

Distance to 15 pixels and the Number of

steps to 30. Make sure Expand is selected

for Direction. Turn on the other layers and

you will see a slight glow behind your

blue outline. To add the final touches to

this effect we want to give it a slight

alpha. For this we need to convert it into a

MovieClip or Graphic. Because we will not

be applying code to the shadow a graphic

will be fine. Select this layer and choose

Modify > Convert to Symbol (F8). Give it a

name, choose Graphic for Behavior, and

make sure the Registration point is in the

top left corner (see Figure 2).

I usually name all Graphics

gpc_name, MovieClips mc_name, and

Buttons btn_name. This allows you to

keep the library much more organized.

Once it is a Graphic we can adjust the

alpha value. Select the graphic then

select Alpha from the Color property in

the Properties Inspector. You can play

with the alpha but I chose 75%. 

Now let’s convert everything we have

done to this point into a graphic named

gpc_albumBack. This will put everything

we have done on one frame and give us a

neater main timeline. It also allows us to

position the entire section without worry-

ing about selecting multiple frames. 

Using the same method listed above,

make another UI element that will hold

your thumbnails and large images. Once

you have done this move both UI ele-

ments to the same layer and name it UI.

Since we are going to place both the

thumbnails and the large images in the

same container we need to add some-

thing to make a clear division between

the content. To do this, make a new layer

above the UI layer. Select the Line Tool

(N), change your stroke color to orange,

and in the Properties Inspector set a 1.5

pixel dotted stroke. Draw

three lines, one in the

albums section – to separate the title

from the album title, and the other two in

the main section, to separate the pics

title from the thumbnails and the thumb-

nails from the large image. 

Using the Text Tool (T), change the

property to Dynamic Text and create a

textfield at the top of the album section,

and two on top of the main section. The

first main section textfield should read

“Pics :: ” while the second is empty, await-

ing text. We chose Dynamic Text to

embed the font we want to use for the

album instead of using a system default

font. To embed fonts, select the textfield

and in the Properties Inspector choose

Character. Then you can specify the

ranges you wish to embed or type the

individual characters you would like to

include (see Figure 3). 

We need to set up the ScrollPanes

needed to house the thumbnails and the

large image. Open the components panel

(Windows > Development Panels >

Components) and select the ScrollPane

from the UI Components set. Drag two

instances of the component to the Stage;

you can add them to the same layer as

the text and lines. Resize one component

to fit within the thumbnail area (438x50)

and name it thumbs_sp. Resize the other

to fit into the large image area (438x430)

and name it large_sp. 
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listing 1

After setting up the ScrollPanes we

need to create our Thumbnail and Album

MovieClips. These clips are attached to

the stage at runtime. To make the Album

MovieClip, select the Text Tool and draw

a textfield roughly 138x54. Select

Dynamic Text, give it an instance name of

name_txt, set the font to _sans with a

font size of 10, and a color of #003366.

Make the textfield multiline as well. John

will touch on why we use multiline later.

Now we need to Modify > Convert to

Symbol (F8), give it a name of Album,

and make the registration point the top

left corner; don’t worry about the link-

age. Delete the MovieClip from the stage.

For the Thumbnail MovieClip we

need to do a little bit more. First, select

the Rectangle Tool and draw a rectangle

40x40 on the stage. Copy and Paste in

Place the rectangle you just drew. Select

the top rectangle only and Modify >

Convert to Symbol. Give it a name of

Mask, click OK, and give it an instance

name of mask. In the source file you will

see I changed the tint of this MovieClip

so you could tell the different between

the two but this isn’t mandatory. Select

both the Mask MovieClip and the other

rectangle you drew then Modify >

Convert to Symbol giving it a name of

Thumbnail. What we just did was create a

background and a mask for our thumb-

nail. Now we need to do two more

things. Double click the Thumbnail

MovieClip to enter its timeline, if you are

not already there. Highlight both items

and Modify > Timeline > Distribute to

Layers. Now you have two layers. Make

sure the Mask MovieClip is on the top

layer and rename this layer Mask, if it isn’t

already. If you have an empty layer sim-

ply delete it. Double click the Mask layer’s

icon and select Mask from the radio but-

tons. Do the same for the other layer but

select Masked. That’s it. Return to your

main timeline, delete the MovieClip from

the stage, and prepare to put the finish-

ing touches on the design. 

The last thing to do concerning the

design to is import our header image.

Select File > Import > Import To Stage

and choose the image you wish to insert

as your header graphic. Name this layer

UI Elements and you are done. The stage

should now look like Figure 4. 

Now the app is looking good so we

can turn it over to John to show you how

to make it work. Take it away John. 

Return of the Sleepy Eye

Huh...what?!?!?!? I was just resting my

eyes but I was listening the whole time. If

I ever get to design something in Flash I’ll

be sure to try your techniques, although

I’d probably just have you do it as usual.

Next month we are going to pick up

where we left off and I’ll show you how

to bring this together. This is actually a

very useful application that can bring a

lot of mileage to a client or to you. While

you are waiting please contact me via e-

mail, mxdj@jdevinc.com, with any

requests about this article in particular

that you would like to see clarified in the

following article(s). I hope you enjoyed

Mike’s information on setting up the

Flash Interface. If you have any questions

about the design feel free to email Mike

at info@michaelhagel.com. Get ready for

Round 2! 
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<cfsilent>

<cfapplication sessionmanagement="yes"

sessiontimeout="#CreateTimeSpan(0,1,0,0)#"

applicationtimeout="#CreateTimeSpan(1,0,0,0)#">

<cfif isDefined("URL.blue42")>

<cfoutput>

<cfset StructClear(Session)>

<cfset StructClear(Application)>

</cfoutput>

</cfif>

<cfparam name="Application.title" 

type="string" default="Photo Album">

<cfparam name="Application.path" 

type="string" default="assets/pics">

<cfif NOT isDefined("Application.data_cfc")>

<cfset Application.data_cfc = CreateObject("compo-

nent", "assets.cfcs.data")>

<cfset Application.data_cfc.setupAlbums()>

</cfif>

<cfif NOT isDefined("Session.albumQ")>

<cfset Session.albumQ =

Application.data_cfc.albums>

</cfif>

</cfsilent>
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ne thing was abundantly clear

at the 2004 MAX conference in

New Orleans: the third-party

Flash market is growing rapidly. This is

due to Macromedia’s decision to provide

APIs and open standards. The result of

this decision is that the Flash developer

will now have a virtual cornucopia of

exciting new tools that will increase pro-

ductivity and flexibility.

One of the most interesting of these

new tools is put out by a California com-

pany called Infommersion and is called

Xcelsius. This tool will allow you to con-

nect a Microsoft Excel spreadsheet into a

self-contained Flash file that can be dis-

played on the web or even exported into

a PowerPoint presentation. Once inside

the Flash file, you can use powerful Flash

components to create “what-if” scenarios.

If all that isn’t enough, you can then save

the “what-if” results back to the original

spreadsheet.

Let’s look at an example.

When we first open Xcelsius you see a

screen similar to Figure 1.

Xcelsius has 42 built-in components

and 9 chart formats to assist you in put-

ting together a dynamic presentation.

One could easily assume that as this

product grows, even more components

will be available. However, even if that

does not happen, what is available now

will more than handle most needs.

We begin by selecting the type of

component or chart you want to use. In

this example, I will use the Bar Chart and

then place that chart where I want it. 

Figure 2 shows some unique additional

components that are available.  While we

don’t have space to show all of them, there

are components featuring U.S. and

European maps, backgrounds, prebuilt but-

tons, tables, and grids.

For this example, I select the

Horizontal Slider and place it right below

the Bar Chart. The components can be

moved and resized easily. Our screen

now looks something like Figure 3.

One tool I found handy is an Object

Browser. While our example has only two

objects in it, you could easily build more

complex graphics. The browser is shown

in Figure 4. Here we can select, hide, and

rename components.

The next step is to link our compo-

nents to a Microsoft Excel worksheet. This

is just a simple matter of clicking on an

icon and browsing to the file you want.

However, this also brings me to my one

real quibble with this program.

Xcelsius is not just linked to the Excel

worksheet, but to Microsoft Excel version

2003. This is because it uses XML as the

connecting technology. For most users,

this might not cause a problem. 

However, if you are an OpenOffice user,

as I am, Xcelsius appears to be unusable.

To do this review, I had to install Excel on

my computer. With more and more users

switching technology, I hope

Infommersion addresses this issue with

future updates.

After the linkage is created, the rest is

simple. If you know how to create a chart

in Excel you can easily use Xcelsius. You

simply go to the chart, right-click, and

select Properties. From here on, the style

of the menus and dialogue boxes is very

much like you would find in Excel. You

can assign cell ranges for the X and Y

axes, define chart properties, and even

enter chart titles. 

You have to repeat the same process

for the slider (or whatever variable compo-

nent you may be using). In my test, I

bound the slider to a cell in the worksheet,

which will vary for “what-if” scenarios. If

there were to be more than one variable, I

could easily handle that by placing multi-

ple control components and binding

them to the appropriate cells. Once again,

all of it was extraordinarily easy to do.

The last step is to export the finished

file to the format you would like. In most

instances you will want to do this as a

Flash .swf file. To do this, I simply selected

the File > Export option. As a handy fea-

ture, I could have previewed the export

first.

When I ran the Flash movie, I was able

to move the slider and see the chart

respond to the variable the slider was

changing. Of course, in the background

XML had the .swf file bound to the work-

sheet, and the slider was also varying the

cell it was bound to. The results were

truly impressive. 

Among the export options were the

aforementioned .swf file, a Powerpoint slide,

HTML, and a Flash file attached to an

Outlook e-mail. What more could you want?
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Some of the other components can

quickly and easily give you spectacular

results. For example, you can use the Map

component (U.S. or Europe) and tie each

state into cells of the worksheet (see

Figure 5).

Unfortunately, using static print (as

you see here) does not do this product

justice. To truly experience it, you

should go to their Web site at www.

infommersion.com. There you can test

drive some of the features and really

see them in action. You can also

downoad an evaluation copy of the pro-

gram. 

As of this printing, Xcelsius is available

in three versions. The Standard edition

has all 42 components as well as most of

the functionality I showed in this review.

This sells for $195.

The Professional edition gives you the

ability to save the results back to Excel as

well as some additional connectivity

options. Also, you can trigger the XML for

updates using JavaScript as the event

trigger. This edition goes for $495.

The Enterprise edition is for network

licensing situations and you would need

to contact Infommersion for pricing.

Summary
Once you try it, I’m sure you will agree

that it is rare to see such incredible power

in such a simple to use package. If you

want to make your presentations exciting

and interactive, Xcelsius is a must.
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f r i e n d

W
ell, there's a chill in the air. The leaves have fallen, 

the wind is brisker, and sometimes, even in early 
November, there's that “scent of snow” in the air. In the 

lead-up to the holiday season, I have created a two-part 
series that uses both Fireworks and Dreamweaver. The 

end result will be a fun little “build your own” snowman 
Web page. In Fireworks we will create all the essential 

ingredients for our frozen friend. Then, in Dreamweaver, we’ll 
use the Drag Layer behavior to create a Web page where we 

can move all the snowman pieces together and build our own 
snowman online. This is a great opportunity for our friends to the 

south who don't even get snow to have a little winter fun. 

by jim babbage
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We will also make use of a different

export option in FW: Export as CSS

Layers. This is a little known – or little-

used – feature, and comes in quite handy

for jumpstarting our Web page. 

This concept could have many dif-

ferent uses: visual quizzing, jigsaw puz-

zles, or other holidays, just to name a

few.

Setting the Scene
1. To begin, create a new Fireworks docu-

ment that is 760 pixels wide x 420 pix-

els high. In the long run we won’t

need all of this space, but I find it use-

ful to set up dimensions based on

actual view port sizes. Everything we

create in FW will be vector based, so it

will be no problem to scale objects

larger or smaller. 

2. Use the Rectangle tool and draw a box

identical in dimensions to your canvas.

The shape will act as our backdrop for

our winter scene. With the rectangle

still selected, go to the Properties

inspector and change the Fill Category

from solid to Gradient>Linear (see

Figure 1). 

3. We’ll customize the gradient from its

default settings so that it changes

from light blue (#00CCFF) to white

(#FFFFFF), and then change the direc-

tion of the gradient so that it travels

from top to bottom, rather than left to

right. 

4. When you are happy with the gradi-

ent, name the layer “bkg” and then

lock the layer by clicking on the

lock/edit box in the Layers panel (see

Figure 2). This will ensure we don’t

select or use this layer accidentally.

Now let’s build our snowman!

Yo, Frosty!
First we will create the giant snow-

balls needed for the body. 

1. Select the Ellipse tool from the Vector

shapes in the Tools panel. 

2. Set the Fill Category to Gradient>

Ellipse (see Figure 3). The gradient col-

ors need to be a very light grey

(#DBDBDB) for the starting color and

white (#FFFFFF) for the end color. This

will help add some dimension to the

snowballs so they don't look so flat. 

3. Set your Stroke settings to the follow-

ing:

– Color: #CCCCCC

– Tip Size: 15

– Category: Charcoal>Soft

– Edge: 50

– Texture: Grain at 30% 

4. Holding down the Shift key, drag an

ellipse that is about 160 pixels in diam-

eter. This will be our template for the

body. Once drawn, the gradient will

not be in the correct position. Select

the Pointer tool and drag the gradient

by its axis point to a position similar to

that of Figure 4. Adjust the gradient

control arms so they are similar to

Figure 4 as well. 

Notice that because our bottom layer

is locked, FW automatically creates a new

layer for the ellipse to reside in. Name

this layer “snowman.”

5. Press F8 to turn this shape into a sym-

bol. 

6. Give the symbol a name, like “snow-

ball” for instance, and choose Graphic

as the Symbol Type. 

7. Click OK. We’ll use instances of this

symbol for the tummy and head of the

snowman (see Figure 5). 

What are symbols and instances? A

symbol is a master copy of an object in

Fireworks. It could be a vector shape or a

bitmap element. Symbols are saved in

the Library tab of the Assets panel, and

can be reused over and over again. The

benefit of using symbols is saving time.

You are saved from having to redraw or

copy/paste an object on your canvas,

should you need additional versions of

that object. 

An instance is a copy of the symbol

and is created when you drag the symbol

from the Library tab to the canvas. If you

edit a symbol, all the instances of that

symbol will change to match the symbol.

You can also make some custom changes

to the instances in terms of scaling, Live

Effects, Opacity, and Blend Mode. These

customizations are only applied to the

selected Instance. 

8. Open the Library tab of the Assets

panel and you should see your symbol

sitting there. To bring an instance of it

to the canvas, click and drag the sym-

bol icon to the canvas. When you let 
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go of the mouse a new instance will

appear. This is the tummy (or torso)

of the snowman. It needs to be

smaller than the base, so we will

scale it numerically. 

9. Go to Modify>Transform>Numeric

Transform (Ctrl/Cmd+Shift+T). Set

the Scale Values to 80%, as seen in

Figure 6. 

10. Hold down the Alt/Option key and

using the Pointer tool, click and drag

the tummy section upwards. This is

another way to create an Instance

(or a copy of anything, really) on the

canvas. You'll see that we now have

two identically sized ellipses and

one larger one. 

11. With the top ellipse selected, press

Ctrl/Cmd+Shift+T to bring up the

Numeric Transform dialog once

again. The previous settings of 80%

should still be in place. Press OK. 

12. Position the three ellipses so that

they overlap to your liking.

13. Shift+click each ellipse so that you

select all three shapes. 

You can also Shift+click in the Layers

Panel, or use the Pointer tool to drag

over all three shapes. 

14. Go to the Align panel. Make sure that

the icons for To Canvas and To

Anchors are both deselected (they

will look orange if selected). 

15. Choose the Align Horizontal Centers

icon (see Figure 7) to line up all three

snowballs. 

16. Rename each object in the Layers

panel by double-clicking on the

default name. Keep the names short,

with no spaces. 

And Two Eyes Made Out of
Coal . . . 

The next thing we need is a lump of

coal. This single graphic will serve multi-

ple purposes: eyes, mouth, and buttons.

We just need to create one, then turn it

into a symbol. 

1. Use the Ellipse tool once again to draw

an oval, approximately 14 px wide by

18 px high. Fill it with solid black. Set

the Stroke Properties to:

– Color: #000000 

– Tip Size: 1 

– Category: 1-Pixel Soft 

– Edge: 0 

– Texture: Grain at 50% 

2. Apply an Inner Bevel Live Effect. Go to

the Effects area of the Properties

inspector and click on the + sign.

Choose Bevel And Emboss>Inner

Bevel. Match your settings to those in

Figure 8.

3. Convert this shape to a symbol by

pressing F8. Name it “coal.”

4. Drag eight more of these instances

onto the canvas, for a total of nine

lumps of coal. Place them accordingly.

Leave a bit of a gap between two of

the "mouth" coal pieces. Figure 9

shows my positioning.

5. When done, name each object via the

Layers panel. Oh, and save your work if

you haven’t already.

Carrot Sticks, Anyone? 
Okay, the real Frosty had a button

nose, but I like the carrot method. 

1. To create our carrot nose, select the

Polygon tool. Set the Polygon

Properties to match Figure 10. 

2. Drag and create an equilateral triangle,

with a flat, horizontal base. Set the fill

color to orange (#FF9900) and the

Stroke Properties as seen below:

– Color: #000000 

– Tip Size: 1 

– Category: 1-Pixel Soft 

– Edge: 0 

– Texture: Grain at 0% 

3. With the triangle selected, choose the

Scale tool. We want the carrot to be

long and skinny. Do this by dragging

any of the center control handles. 

4. We also want the flat end to be a little

rounded. Choose the Pen tool, click in

the middle of the bottom line of our

shape, and drag the tool so that you

pull out the Bezier Curve control arms.

Drag until your cursor is resting over

the bottom right anchor point for the

triangle.

5. Choose the Subselection tool and pull

the newly created anchor point down

a few pixels, until the base of the trian-

gle is curved (see Figure 11).

6. Go to Modify>Transform>Rotate 90

CCW to point our "nose" in the correct

direction. 

7. Let’s add a few curved strokes to make

the carrot nose look more rounded. 

8. Zoom in to at least 400% so that the 
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nose fills the canvas fairly well.

Choose the Pen tool again. Click it

about 2/3 of the way up the nose

(Okay, that sounds gross. Kids, don't

try this at home) to set an anchor

point. 

9. Move your mouse down to the bot-

tom of the nose and then click and

drag to create a curved line.

10. Double-click on the end anchor to

disengage the Pen tool. 

11. Select the Subselection tool, adjust

the curve as needed, and position

the curve so that it rests on the

nose's black stroke.

12. Create a few of these by duplicating

the one just drawn. Position them

randomly, attached to the top and

bottom strokes of the triangle. You

can use the Subselection tool to

alter the curve and the height of the

line. Figure 12 shows my completed

nose.

13. When you have all the curves posi-

tioned as you like, use the Pointer

tool to select each object (including

the carrot nose itself ).

14. Press Ctrl/Cmd+G to group all the

carrot objects together. Make sure

you don't select any other objects

by accident. Hold down the Shift key

to make multiple selections. You can

also do this in the Layers panel,

rather than the canvas area if you

find that easier to do. 

15. Use the Pointer tool to position the

nose on the snowman's face. If the

nose is too big or too small, you can

use the Scale tool to adjust it. 

16. One last change. To give the carrot

some dimension, we’ll change the

fill from solid orange to a linear gra-

dient. We can do this even after sev-

eral objects have been grouped

together. 

17. Zoom in on the nose again. Use the

Subselection tool to select just the

triangle shape of the carrot. 

18. Go to the Fill Category drop-down

menu and choose Linear. The default

gradient will appear, moving from

black to orange. Immediately switch

to the Pointer tool. The gradient con-

trol arm will appear on the nose. 

19. Adjust the gradient’s direction so

that it runs from top to bottom,

rather than left to right, with orange

on top. 

20. Move the gradient control arms clos-

er to the wider end of the carrot.

Shorten the length of the gradient

so that most of the carrot is orange,

and finally, adjust the gradient col-

ors so that the black becomes a

medium grey. As you can see from

Figure 13, our snowman is taking

shape nicely. 

Put That in Your Pipe and
Smoke it! 

Yes, I am the king of the cheesy sub-

headings, in case you were wondering.

Our next mandatory snowman element –

even in this day and age of the non-

smoking bylaw – is the pipe. Again, vec-

tor tools to the rescue. 

1. Choose the Rounded Rectangle tool

and draw a small square. 

2. Zoom in on the shape so you can see it

better. Don’t worry about fill colors at

the moment. 

3. Because the rounded rectangle is an

auto shape in Fireworks 2004, it will be

easy to create the bowl of the pipe.

Notice all those yellow diamonds?

Those are control points for the auto

shape. Hold down the Alt/Option key,

and drag one of the two bottom con-

trol points toward the middle of the

shape. 

4. Do the same with the other bottom

control point. This gives us our round-

ed bottom to the bowl of the pipe. 

The Alt/Option key lets you control

the radius and shape of each individual

corner. If you click the control point with-

out dragging, you change the shape of

the corner (see Figure 14). 

5. Change the fill to a linear gradient,

if that isn’t already in place. 

6. Customize the fill colors so that the

left side of the pipe is a medium-

dark grey, and the right side is black. 

7. Remove the stroke – if any – by

clicking on the stroke color and

choosing none. (This is identified in

the swatch box by that universal

“no” sign: a red strike-through.) Set

the length of the gradient so that it

ends 2/3 of the way across the pipe

bowl (see Figure 15). 

8. Create the pipe stem by drawing a

long, thin, rounded rectangle that is

solid black. 

9. Move the two objects closer so that

the pipe stem seems to merge with

the pipe bowl.

10. Shift+Click to select both objects,

and then group them together by

pressing Ctrl/Cmd+G.

11. Choose the Transform tool to rotate

the pipe to a jaunty angle. If you

wish, you can add some smoke by

choosing the Vector Path tool and

setting the Stroke Properties to the

settings below:

– Color: #CCCCCC 

– Tip Size: 10 

– Category:  Unnatural > Viscous 

Alien Paint 

– Edge: 30 

– Texture: 0% 

15. Then simply draw a vertical squiggly

line. Instant pipe smoke! If you do

add the smoke, be sure to group it

with the other parts of the pipe. 
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Extension of the Month

nless you run your own Web analytics

package, the Web statistics you get from

your ISP aren’t always that easy to follow.

The amount of data presented in your

standard Web report can be overwhelming and

often poorly organized. Even worse, you usually

don’t get any information about your visitors’

screen size or whether they have JavaScript

enabled (two  things that may affect how you

develop your site).

Fortunately, Dreamweaver users can turn to a

simple and inexpensive server-side solution from

DWUser.com. DWStats is a Dreamweaver

Extension that lets you track user data on your

site. A password-protected page provides infor-

mation about how many unique visitors have

come to a page, where they came from (for exam-

ple another page on your site or via a search

engine), what

browser they used,

whether JavaScript

is enabled, what

country the visitor

is from, what oper-

ating system they

used,  and the

screen resolution

and color depth. 

The extension

works with either

ASP, PHP, or ColdFusion sites, but you can track

visitors on non-dynamic pages – i.e. plain HTML

files – as well. It installs a new option on the Insert

Bar – DWStats. Using it you can insert tracking

code on any Web page on your site. In addition,

the extension installs some server-side code that

controls the display and access to these Web sta-

tistics. It’s fast and easy. 

Not that the extension doesn’t have a few

drawbacks. Statistics can only be viewed on a

page-by-page basis – in other words, there isn’t a

summary page that shows total visitors to all

pages you’re track-

ing.

But all in all

DWStats provides

a quick way to cap-

ture important

user data – includ-

ing data like screen

resolution that isn’t

captured in normal

Web logs.

• • •

Have a favorite extension? Is there an exten-

sion you just couldn’t live with out? We’re always

on the lookout for awesome extensions, so drop

us a line at: DaveMcFarland@sys-con.com

Dave McFarland is the Dreamweaver editor of

MX Developer’s Journal and author of

Dreamweaver MX 2004: The Missing Manual.

Find out about his latest projects at www.saw-

mac.com DaveMcFarland@sys-con.com

DWStats
Extension Developer: DWUser.com

Developer Web Site: www.dwuser.com

Price: $17.99

Supported Server Models: ASP, PHP,

ColdFusion

u

É2004 SUNTECH 3 INC. ALL RIGHTS RESERVED. ALL PRODUCT NAMES ARE REGISTERED TRADEMARKS OF MACROMEDIA, INC.
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The Vector Path tool creates a path

from whatever you draw with the mouse.

Each time you change direction, a new

vector control point gets added. You

won't see those points until you stop

drawing and let go of the mouse. 

Give That Guy a Hand . . 
or Two 

Your snowman needs a way to wave

at passers-by, so next on the list are the

arms. You can create these in a couple of

different ways:

• The Pen tool

• The Vector Path tool

We’ve had a lot of practice with the

Pen tool, so I will make my snowman's

arms with the Vector Path tool. Because

the path is created by how you draw, the

resulting twig arms should look a little

more natural. The stroke settings are as

follows:

• Color: #9D4F00

• Tip Size: 3 

• Category: Pencil > Graphite 

• Edge: 0 

• Texture: Grain at 30% 

1. Draw the arm as a diagonal line. 

2. Then draw a “V” shape for the hand.

Because of the nature of the Vector

Path tool (and the shakiness of your

drawing hand), you will probably see a

lot of control points.

3. We can remove a lot of these unneces-

sary points, thus simplifying the path,

by going to Modify>Alter Path>

Simplify. 

4. Set a value of 10 and press OK. You

should see many of the extra points

disappear. 

Productivity Tip: You can replay the

above step by selecting your next object

and pressing Ctrl/Cmd+Y, or going to

Edit>Repeat Simplify Paths. 

5. Move the two objects together and

then group them. 

6. Draw your other arm in the same man-

ner, or use the Pen tool if you like.

7. Position the arms on either side of the

body. To add to our sense of depth,

change the stacking order of the left

arm so that it appears to be under-

neath the tummy object. You can do

this by either dragging the arm layer

lower in the Layers panel, or by select-

ing the object and pressing

Ctrl/Cmd+Down-arrow key. Keep

pressing this key combo until the arm

moves behind the tummy. 

He’s One Cool Fashion
Victim 

Our last two elements are fashion

accessories. No self-respecting snowman

would be caught in public without a hat

and scarf of some sort.

1. For the scarf, use the Pen tool to draw

a shape that has a bit of an “S” curve to

the top and bottom. Make sure to

close off the path by clicking on the

starting control point, as we have done

previously in this tutorial. As always,

you can use the Subselection tool to

tweak the shape. For my scarf, I creat-

ed a duplicate of the first shape and

rotated it a bit.

2. For a fill, choose Pattern>Cloth-purple

from the Fill Category drop-down

menu in the Properties inspector.

Select both objects and group them.

Remember to give the grouped object

a name in the Layers panel.

3. Our snazzy, yet well-loved top hat is

created with two vector shapes: an

ellipse for the brim and a rectangle for

the crown. 

4. Draw your oval shape for the brim

using the Ellipse tool. 

5. On top of that draw a rectangle for the

crown with the Rectangle tool. 

6. We want to make the top and bottom

of the rectangle a little rounded and in

order to do that, we need to un-group 

the shape. A standard vector rectan-

gle is a grouped shape by default.

Press Ctrl/Cmd+Shift+G to un-group

the shape. 

7. Much like we did with the carrot,

add a control point to the top and

bottom of the rectangle shape. 

8. Use the Pen tool to drag out the

Bezier control arms, and the

Subselection tool to drag the control

point to create a subtle curve to both

the top and the bottom of the crown. 

9. Add a few more control points to the

sides of the crown, but do not drag

out the curve handles. Instead, once

the points have been added, use the

Subselection tool to drag some of

these points inwards and outwards.

This will give our top hat a bit more

of an aged, worn look. 

10. Figure 16 shows the control points

for my hat.

11. Select both objects and group them

together. 

12. Use the Transform tool to rotate the

hat.

13. Move the hat into place on our

snowman's head.

14. Go through the Layers panel and

make sure each object is named,

then save the file.

TA DAAAAA! Our snowman is com-

plete (see Figure 17). Now let’s get him

into Dreamweaver.

Exporting the Snowman to
Dreamweaver

There are at least two ways to

approach this:

1. Hide the background layer, move all

the objects apart so they do not over-

lap, create a custom slice for each

object, and export all slices. 

The advantage here is that you can

set custom optimization settings for

each slice. You can also add Alt text in

the Properties inspector for each

image. The downside to this method is

that you will have to completely

rebuild your snowman in DW, before

you can even begin to set up the Drag

Layer behaviors. You will have to export

the background separately so that it

doesn't show up as the background in

each of your snowman image slices. 

2. Distribute all of your objects to sepa-

rate layers while in Fireworks and
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export your snowman – in place – to

Dreamweaver as positioned, CSS layers.

The advantage here is that your initial Web

page will look exactly like your FW creation.

The disadvantages are that you cannot cre-

ate custom optimization settings for each

element, and Alt text will have to be added

manually in DW. You will have to decide on

a single file format and optimization setting

for everything. As a result, some of your files

may not be as small in file size as you may

like, or may not look as perfect as you wish.

In my case, there really is not much of a

decision factor; I want transparent back-

grounds around each image so that they just

look like the original shapes, not like shapes

inside of boxes. This means that a JPEG is out of

the question. Plus, it's a lot easier to finish the

page when half the positioning work is done. 

We will, however, temporarily create and

use one slice for our background gradient. 

1. Click the Eyeball icon that is to the left of

the snowman layer. This will hide our cre-

ation from view.

2. Unlock the bkg layer by clicking on the lock

symbol. 

3. Select the gradient background, and then

Right/Ctrl+Click to bring up the Context

menu. 

4. Choose Insert Slice from the menu. Your

background will be covered in a slice indi-

cated by the light green tinge.

5. In the Optimize panel, set the format from

GIF to JPEG, and set the Quality to a value

of 70. 

6. Set the Smoothing to a value of 1, to mini-

mize any JPEG artifacts. Because there is no

real detail in this background, smoothing

the image won’t hurt the quality or sharp-

ness of the background (see Figure 18). 
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7. Right/Ctrl+Click the

slice itself to bring up

the Context menu and

choose Export

Selected Slice. 

8. When the Export dia-

log appears, browse

for the directory

where you will place

your snowman Web

page and graphics. At

this point, it doesn’t

matter if you have a

DW site set up or not.

Ideally, though, you

should export all

these elements into

their own, unique

folder on your hard

drive. Make a note of

the folder.

9. Hide the slice by click-

ing on the Hide/Show

Slices and Hotspots

icon on the toolbar. 

10. Hide the Background

layer and make the

snowman layer visible

again. 

By exporting as CSS Layers, the snow-

man will look just like he does in

Fireworks, but each object will be a sepa-

rate graphic.

How, you ask, will we do this? If an

image isn’t sliced, then the obvious result

is one large graphic. If we use a standard

export setting and do not prep our file

accordingly, you are exactly right. But

we're smarter than that, aren't we? 

Here’s how:

1. Take one more look at your Layers

panel. Make sure that each object has

a name. 

2. Click once on the layer's name in the

Layers panel. This will select all of the

objects quickly.

3. Here's the cool part. Go to

Commands>Document>

Distribute to Layers . Instantly, each

object is put in its very own layer! Cool,

huh? Take a few minutes and name

each layer based on the object name. 

Make sure that you do not use any

spaces or special characters in the layer

names as these will become the file

names for each graphic. 

4. Save your work. 

5. Reset your Optimize panel as below:

– Format: GIF

– Palette: Web Adaptive

– Colors: 256

– Transparency: Alpha 

6. Cool Part #2 - Go to File>Export. When

the dialog box opens, set the file name

to an appropriate name. If you leave it,

FW will use the file name of your PNG

file, which may be fine as well. 

7. In the Save as Type combo box,

choose CSS Layers (HTML).

8. In the Source combo box, set your option

to Fireworks Layers. To keep the final files

as compact as possible, check off the Trim

Images option. You can also elect to put

the images in a subfolder, but since we

did not do this with the background

image, I will leave this option unchecked.

Figure 19 shows my settings. 

9. Press the Save button and FW will

export your layers as image files, and

insert them into DW as CSS posi-

tioned layers inside the HTML page.

When you are returned to Fireworks,

save your file one last time. 

10. As a last step, open a Web browser

and locate your snowman.html Web

page. Open it to view your page. Your

snowman appears just as it was creat-

ed! The background won’t be there,

but that's fine; we'll drop that in (and

do lots more) when we move into

Dreamweaver next month for part 2. 

Congratulations on building your first

snowman without even getting your

hands cold! 

We did quite a few different things here:

• Lots of Pen tool practice

• Creating custom vector shapes

• Editing vector shapes

• Working with strokes

• Working with custom gradients

• Working with FW layers 

• Exporting using the CSS method, 

rather than traditional export options

Give yourself a pat on the back for

this one. Next month in part 2 we will

open the FW-generated Web page in

Dreamweaver, add our background layer,

tweak the HTML, and add Drag Layer

commands to each layer.  
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s a writer and a trainer, I am

frequently asked how to make

the popular curved navigation

graphic. You know the one, top banner

area, side bar with an inside curve (see

Figure 1). Using Fireworks you’ll be

amazed at how simple this can be. You’ll

learn how to make the curve in two dif-

ferent ways. One way is automated and

the other is not. By learning how to do it

yourself, you’ll learn a technique that will

allow you to make any shape, not just the

inverted L.

Once you learn how to make the

graphic, then what? What do you do with

it? Export it from Fireworks and use it as a

Web page? You could, but please don’t

even think of doing that. Although

Fireworks can generate HTML code, it is

not what Fireworks does best. Fireworks

is a graphics editor, so let’s use it to its full

potential. Once you learn how to slice,

optimize, and export the graphic, you’ll

then learn how to put it together in

Dreamweaver. 

Curved Navigation Graphic
1. Choose File>New. In the New in

Document dialog box, type 700 in to

the width field. In the Height field,

type in 400. For the Canvas Color, click

on the radio button next to White to

select it. Click OK.

2. In the Tools panel select the Rectangle

tool.  Click on the canvas and drag on

the rectangle tool to draw a rectangle,

don’t worry about the size.

3. In the Property inspector (below the

canvas area), change the width to 700

and the height to120. Click in the Fill

color box (which has a paint bucket)

and use the dropper tool to select the

color you’d like. You can even select a

color from a graphic on your page

which is a great way to get colors that

are complementary to your design

images.

4. Draw another rectangle and in the

Property inspector, change its Width to

120 and Height to 400. I’m using green

so you can better see what I’m doing.

5. Place the rectangles together to form

an upside down L shape  (see Figure

2).

Note: I am using two different colors

so you can identify the objects more easi-

ly.

6. Shift+select both rectangles.

7. Choose Modify>Combine Paths>

Union. The shape is now one shape

instead of two (see Figure 3).

Note: The shape on the bottom will

become the color of the new combined

shape.

You’ve just learned how you can

combine any shapes together using the

Union command. With this technique

you are not limited to the same size for

the top and the side. You are also not

limited to rectangles. The easy way to

make a basic L shape with sides and top

of the same thickness is to use a Smart

Shape.

Smart Shape
As an alternative, you can make the

basic L shape using one of the smart

shapes that ships with Fireworks.

Note: In the flyout menu of the

Rectangle tool, you’ll see the L-Shape

tool. Select it and drag it onto your can-

vas. Notice the yellow diamonds. If you

drag on the one on the top end or the

bottom center, it will make the side or

top longer. To increase the width of the

top and side, drag on the yellow dia-

mond on the bottom right side of the left

bar. 

You can use either method of produc-

ing your navigation shape before pro-

ceeding to the next step.

Cookie Cutter
1. Select the Rectangle tool and drag a

rectangle on the canvas.

2. In the Property inspector locate

Roundness and type in or select a set-

ting of 50. Set the Width to 650 and

the Height to 400.

Note: I made my rounded rectangle

gold so you could see it more easily; any

color will work and will have no effect at

all on your graphic. This graphic will be

used as a cookie cutter.

3.  Position the rounded rectangle into

the corner of the L shape. Place it so

that what you see beyond the rounded

rectangle is what you want. Whatever

is below this “cookie cutter” will be

removed (see Figure 4).

Note: Be sure that the curve of the

rounded rectangle clears the end of the

top of the shape and the bottom of the

side shape. Otherwise you won’t get a

nice straight edge. If it doesn’t, make

your rounded rectangle larger.

4. Shift+select the L shape and the

rounded rectangle; it doesn’t matter

which object you select first.

5. Choose Modify>Combine

Paths>Punch. You now have an L

shape with a curved inside corner (see

Figure 5).

6. In the Property inspector, click the plus

sign next to the word Effects and

select Shadow and Glow>Drop

Shadow. Change the Distance to 10

and the Opacity to 50%.

7. Press Enter (Return) to activate the

change.

8. Save your file. You are now ready to

slice, optimize, and export the graphic

for use in a Web page.

Slice, Optimize, and Export
1. Select the Slice tool and draw a slice

tutorial

Stretching the Curve

Moving from Fireworks to Dreamweaver 
by joyce j. evans

a
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over the top left corner. Be sure you

get the entire curve (see Figure 6).

You’ll see a light green overlay.

Note: In the Layers panel there is a

layer called Web Layer. You can see any

of your slices here. This is a permanent

layer and can’t be removed.

2. Using the Slice tool, draw another thin

slice for the top bar, making sure you

get all of the shadow. Draw another

thin slice across the side bar as seen in

Figure 6.

3. Select the large corner slice and click

the Preview tab (see Figure 7).

4. Open the Optimize panel and use

these settings: Export File Format: GIF;

the Index Palette: Adaptive; Colors: 16

and No Transparency (see Figure 8).

Note: For a more in-depth explanation

of optimization, see my article in the

October issue (MXDJ, Vol 2, issue 10).

You are using the GIF format because

the image has a lot of flat color. JPEG is

best for photos, GIF is best for flat colors.

You don't need any transparency for this

image. If you did need transparency then

GIF wouldn’t be the best option because

of the drop shadow.

5. In the Property inspector, highlight the

default slice name and rename it

something useful (see Figure 9).

6. Select the top thin slice and change

the optimization to 16 colors; give the

slice a name as you did in step 5.

7. Repeat steps 3–5 for the side slice.

8. Shift+select all three slices (see Figure

10).

9. Right-click (Control-click) on the slice

and select “Export Selected Slice.”

Navigate to the folder you want to

export your images into. It should be a

folder within your root folder for the

site you are building. Don’t worry

about the name of the file, it won’t

affect the slice names you gave the

slices. Notice that the Selected Slices

Only option is checked.

Note: You can also access the Export

dialog by choosing File>Export. I prefer

the right-click method to export specific

slices because the “Selected Slices Only”

dialog is prechecked. Otherwise it isn’t

and I often forget to check it and end up

with a ton of other images I didn’t want.

Any part of your document that isn’t

sliced will be exported anyway (as

defined by the red lines you see after

adding a slice) if you don’t select

“Selected Slices Only.”

10. Click Save to save your file. 

You are now ready to use these three

images to make a stretchy or fluid table

in Dreamweaver. 

Stretchy Table Design
A stretchy table design allows your

graphic to expand with a browse but it’s

not actually an image that is expanding. I

get letters all the time asking me how to

stretch a banner image to fit the browser

window. The answer is, you don’t. What

stretches is either a tiled background

image or a background color. Let’s get

started with adding your graphics to a

Dreamweaver layout.

1. Open Dreamweaver and define a site

for your new design. If you need help

doing this then select Help>Using

Dreamweaver, click on Search, and

type in “Defining a local folder.”

2. In the Insert panel, the Common area,

click the Insert Table Icon. You can also

access this by selecting Insert>Table

(see Figure 11).

3. In the Table dialog box enter 2 Rows, 2

Columns, and a Table Width of 100%.

Be sure to type zeros into the Cell

Padding and Cell Spacing fields. Blank

does not mean zero (see Figure 12). 

4. Click inside the first cell on the left side

of the top row.

5. In the Common panel, click the Insert

Image icon (Insert>Image) and navi-

gate to where you have the images

you’ve saved (see Figure 13).

6. Select the Lft_banner.gif and click

Open. Notice the width of the image;

it’s 164 pixels wide. You can see the

width in the Property inspector.

7. Press the right arrow key on your key-

board to place the cursor in the cell,

and off the image.

9. In the Property inspector change the

Width (W) to 164 and press Enter

(Return). This sets the width of the cell

not the image. In this case the cell will

be the same size as the image. Also

click on the Vert drop down and select

Top (see Figure 14).

Notice, however that the column

(dotted lines) has collapsed against

the image. This cell is now a fixed

width, it won’t get any larger. But if

you add an image in the cell below it

that is larger than 164, the colmun

will stretch to fit the content no

matter what size you set it to be. If

you place a larger image in another
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cell below the image then you will

get a gap in the top row. It’s impor-

tant to note that the Width setting

does not force the cell to remain at

that size.

10. Click inside the right top cell and in

the Property inspector, in the width

field (W) type in 100% (use the per-

cent sign). This cell will stretch to fill

up 100% of the available space. As

the browser window expands or

contracts, so will this column.(see

Figure 15).

Note: If you had a third column you

could set it to a fixed width; the center

would still expand to fill the browser win-

dow.

11. Open the CSS Styles panel in the

Design panel group. Select the +

sign at the bottom of the panel (New

CSS Style).

12. Select a Selector Type of  “Class.”

Type .topbanner for the name. Click

on "This Document Only". Click OK

(see Figure 16).

13. Select the Background category to

open it's options. Click in the

Background Color well. Click the little

right pointing arrow and be sure that

Snap to Web Save is not checked,

then sample the peach color from

the document (see Figure 17).

14. Click the Browse button and navi-

gate to the folder you have your

images in and select Top_banner.gif

(see Figure 18).

15. Choose repeat-x for the Repeat field

and click on OK.

16. Place your cursor in the 100% cell. In

the Tag Selector (bottom of your

document) the <td> tag should be

hightlighted. Right-click and select

Set Class and click on the topbanner

name to apply the style. Another

way to set the style is to click on the

<td> tag and in the Property inspec-

tor there is a Style drop down menu.

Click it and select the desired style.

17. Place your cursor in the left cell of

the second row.

18. Add another new style but this time

name it .sideback. Use the

Lft_side.gif  file as the background

image and set the repeat to repeat-y.

(repeat steps 11–15).

19. Apply the style as you did in step 16.

20. The background images in the top

right cell and the left cell of the sec-

ond row now contain only back-

ground images. This is not consid-

ered content. You can type text

and/or add images to each area. If

you add nothing to either area, you’ll

need to add a small spacer image so

that Netscape 4 browsers can see the

background color.

21. You can now add a header or banner

image if you’d like. Remember, the

image won’t stretch but the back-

ground color will fill the available

space, so be sure it compliments

your image. You can align a graphic

in the cell to the right, left, or center

by selecting each option from the
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Horz drop down menu in the

Property inspector.

22. Save your file and preview it in a

browser (F12). Make the browser

window smaller and larger and see

how your design expands.

Note: When you know your design

needs to fill a browser window, then

design an area that can stretch and still

look good. A good example of this is at

www.primefocus.com. The header on this

page has a texture over the graphic. It’s

almost impossible to match an uneven

texture to an image if the browser

expands. The texture would have to tile.

Click on any of the site’s links to go to an

inside page. The solution is to remove the

texture, add a gray background, and

feather the left edge of the graphic to

fade into the background and align the

image to the right. This way when the

browser expands, the image always

remains to the right.  

Joyce J. Evans is a training veteran with

over 10 years of experience in educa-

tional teaching, tutorial development,

and Web design. She has presented at

conferences such as Macromedia MAX

2003 and TODCON. Joyce has

authored books including Macromedia

Studio MX 2004 Bible, Dreamweaver

MX 2004 Complete Course, and others.

She is a Team Macromedia volunteer

and her work is also featured in the

Macromedia Design/Developer center.

Her Web site is www.JoyceJEvans.com.

joyce@joycejevans.com
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POSTER
 ART

“Posterization” 
    made easy by ron rockwellby ron rockwell
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T
hey just don’t make posters as

they used to. There was a time

when posters were designed to

use as few colors as possible to keep costs

down. Screen printing techniques allowed for

an economical print run, and artists learned to

see and draw people and places in terms of

basic shapes and masses of color. All that sim-

plification became known as “posterization.”

Today you can get your favorite photo

printed in full color within a few days,

and you don’t have to worry about styliz-

ing your artwork to keep costs down. But

there are times when you want to try

something different, and we’ll explore

how easy it is to create a posterized look

in FreeHand. Always on the lookout for a

means to crash either our computer or

the printer, we’ll go on to add special

effects and add life to the poster.

I’m using a photo I took of a 1916

steam locomotive in Cumberland,

Maryland a couple years ago. If you’ve

never seen one of these old trains up

close, you have missed quite an experi-

ence. They’re big, loud, and totally awe-

some. I converted my photo to grayscale

in Adobe Photoshop, and imported the

TIFF document into FreeHand. You can

download the image from www.brain-

stormer.org/loco.jpg, or use any black

and white image you have handy. The

more contrast you have, the more power-

ful the image will be.

Once in FreeHand, select the image

and search the Object Panel for the

Image Adjust icon. The pointer is on

Image Adjust in Figure 1. Image Adjust

allows you to change the lightness

(brightness) and contrast in a black and

white (grayscale) image. The changes you

make only apply to the image as it is used

in this particular FreeHand document;

the original image will remain unaltered.

If you reselect the image and open Image

Adjust at a later time, the adjustments

you’ve made will show in the window so
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you can make minor adjustments or

return the image to normal.

When the panel opens, click the con-

trast arrows to increase the image’s con-

trast, or you can click one of the presets at

the top of the window. You can also select

individual bars and move them up or

down. Each bar represents 16 steps in the

256 levels of gray an image can have.

Obviously you have much more control in

Photoshop’s Levels or Curves controls, but

when you are manipulating an image such

as we are in this instance, Image Adjust

works very well. Figure 2 shows the adjust-

ment I made in the locomotive’s contrast.

The reason I’m compressing the image is to

attempt to make it more powerful and dra-

matic by burying some of the details.

Since the image is grayscale, we have

one other change we can make to it – its

color. Since I plan to print this image, I’m

using CMYK colors. If the image were

intended for the Web, I’d use RGB colors

instead. In the Mixer panel, I created a

dark blue (100C, 100M, 0Y, 26K) and

added it to the swatches panel by click-

ing the Add to Swatches panel. I left the

color’s name at its CMYK breakdown.

Then I selected the image and double-

clicked the new color in the Swatches

panel as shown in Figure 3.

I want the train to be coming out of

the darkness of night, so there are more

alterations to make. I started by tracing

the image in a four-color breakdown to

emphasize the posterization. Double-

clicking the Trace tool brings up the Trace

Tool dialog box; you can see the settings

I used in Figure 4. 

To keep everything in its proper posi-

tion, I immediately group the tracing. For

the record, I save after just about every

step or two because you never know

when something bad is going to happen

to your computer.

Now the fun starts. Start by going to

the Xtras menu and dragging down to

Colors>Name All Colors. That places all

four colors in the traced posterization into

the Swatches panel. Here is where your

color modes come into play. If you’ve cho-

sen an RGB color to begin with, you will

get a set of RGB colors in the Swatches

panel. If you create your color from CMYK

values, then the Name All Colors will pro-

vide CMYK breakdowns for the colors. But

if you’ve chosen to use a PANTONE color

or any other spot ink color, the break-

down will be to CMYK, not percentages of

the spot color. At that point, you’d have a

five-color job instead of a one-color job. If

you want to have tints of spot colors, pro-

ceed as above, but then drag a swatch of

the solid color onto the Tints panel. At

that point you simply move the slider

until you match the various RGB colors

that are in the Swatches panel. When you

get a match, drag the color from the color

well onto the Swatches panel – it will be

named something like “43% PANTONE

488,” and all the tints of the spot color will

separate onto a single negative for the

specific spot color. 

Now, go to Edit>Find & Replace>

Graphics, choose Colors as the attribute,

and select the darkest blue from the drop-

down menu on the From side of the box.

Select Black in the To menu, and click the

Change button (see Figure 5). Change the

next lighter blue to the darkest blue, and

the lightest blue to the next darker blue.

This greatly intensifies the image, but the

white areas are too stark. To get the most

bang for our buck, we’ll use the opposite

color of the medium blue. To achieve this,

drag a swatch of the medium blue to the

Mixer panel, and click on the HLS color

mode button. The color wheel will appear

with a black circle indicating where your

color is in the world of HLS. Click your cur-

sor exactly opposite that black circle – use

an imaginary line going through the cen-

ter of the color wheel, and click the same

distance from the center. This will give you

the complimentary color. Add it to your

Swatches panel by clicking the Add to

Swatches button or dragging a swatch to

the Swatches panel.

The white areas we want to change

are the background of the page. We don’t

want the entire page to be a different

color, and trying to find each and every

white area would be time consuming. So,

go back to the Find & Replace window

and click the Select tab. Choose Color,

and select the color that surrounds most

of the image. In this case, it happens to

be the lighter of the blues. If you have a

tough time distinguishing the different

colors, just use the Eyedropper tool and

drag a swatch onto the Find & Replace

window. Click the Find button, then

choose Modify>Combine>Union to solid-

ify the area and absorb the white areas.

Apply the complimentary color you just

created, and send the object to the back.
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In our case, the window reflections and

highlights on the train and its headlight

turn yellow/gold as seen in Figure 6.

Night skies are usually dark, so now

we’ll create a dark gradient from black to

the darkest blue. Use the Rectangle tool

to drag a box that fills the sky area, and

choose Add Fill in the Object panel if your

rectangle doesn’t have a fill. Send the rec-

tangle to the back. Change the fill type to

Gradient and put black on one end of the

ramp and the dark blue on the other end.

Depending on how you want to light

your sky, you can place the blue end

close to the ground, indicating dawn, or

you can make it look like a bright moon

by placing the blue color at the top –

that’s the route I took in Figure 7.

Okay, the mood is set, but the engine

is just sitting there. To crank up the action

a bit, we’ll add some smoke and steam.

Start by choosing the Calligraphic Pen

tool (hiding under the Pencil tool) and

double-clicking it. In the dialog box, fine-

tune your tool by setting the minimum

and maximum widths to something

obscene – I used 1p0 for minimum, and

12p0. I’m fortunate enough to have one

of the new Wacom Intuos 3 tablets, so

drawing puffy smoke is a pretty easy task

with the pressure-sensitive pen. If you

don’t use a graphic tablet, then you can

change the width of the stroke by press-

ing the left and right Keyboard Arrows as

you draw. The results are the same, only

with the pen you can drink coffee at the

same time. At any rate, draw clouds of

smoke and steam as shown in Figure 8.

Give them a stroke of none and a fill of

the lightest blue in your Swatches panel.

I find it convenient to group objects

like this to keep things simple in case I

want to modify them later. If you do

choose to group them, then you have to
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Subselect them

(Edit>Select>Subselect) to make the

whispy modifications you need. Click

on the Add Effects button and choose

Feather as shown in Figure 9. Adjust

the radius and softness to your taste,

and don’t worry too much about hard

edges at this point.

Now you can deal with the hard

edges by going back to Add Effects and

choosing Blur>Gaussian Blur as shown

in Figure 10. It’s difficult to see your

true results because the paths are

selected. If you deselect them to check

out your progress, then you have to go

back and select all those loose objects

again. That’s one of the main reasons to

group them. One click and you’re set! 

To add more volume to the wisps,

lower the settings in the Calligraphic

Pen tool window and draw more wisps

inside the first ones. Since these shapes

will add more depth and detail to the

smoke clouds, choose Add Effects once

more and apply Roughen. Now go

through the process of adding feather-

ing and blurring as you did earlier. 

The headlight needs some pop, so

draw a cone shape centering on the

lamp, as shown on the left side of Figure

11. Then clone that shape and shift

points inward as shown on the right

side of Figure 12. Since we will be modi-

fying the results with raster effects, be

sure to extend the headlight glow out-

side the borders of the drawing.

Blend the two shapes, and while

the blend is selected, choose Add

Effects and add a Gaussian blur. Add

another effect, this time Basic

Transparency with an opacity that

looks realistic – 80% worked on the

example in Figure 13.  

This pretty much sums up the

drawing itself. To add a semi-fancy bor-

der, start with a pair of rectangles (see

Figure 14), and use the Subselect tool

to create rounded corners. I made

some concave corners at the bottom to

suggest a train tunnel (I like subliminal

messages). The corners were modified

by deselecting the Uniform box in the

Object panel. Once the two main

shapes were designed, they were

cloned and the entire drawing cut and

pasted inside. To make the drawing

faster to work with, the compound

path containing the drawing was
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placed on a layer and the layer hidden.

Then select all the paths and use the

Expand Path Xtra with a width of about 6

points. The larger two paths must be

joined, filled and stroked. Use a clone of

the border shape and use the Inset Path

Xtra with an inset of 2 points and round-

ed end caps. Select points in appropriate

places and choose Modify>Split. Discard

the unwanted paths, but give the remain-

ing strokes a heavy weight with a high-

light (or shadow) color as shown in the

detail in Figure 15. 

Make the drawing layer visible again,

and set the text for the poster’s title.

Astrid Short was used for “Cumberland” in

this example. Change the text color to

match the gold color from the highlights

in the poster, create a clone, and hide it

(View>Hide Selection). Use the Extrude

tool to extrude the visible text, aligning

the left edge vertically, and matching the

perspective of the building’s roof. Set the

lighting for the first light to center, and

the second light source to Bottom Right.

Choose View>Show All to bring back

the text clone. Choose Modify>Join, and

change the fill type to Gradient. You can

change the angle of the gradient by typ-

ing 270 degrees in the Object panel, and

readjusting the location of the gradient

fill control handle, or you can just move

the control handle and spin it to the loca-

tion you want. Change the fill colors in

the gradient to a range of gold to white,

with white at the bottom to indicate that

it’s being lit from below. The finished

effect is shown in Figure 16, along with

more text set in Sycamore Sans. This line

of text was simply cloned, sent behind

the original, and shifted to leave a dark

solid drop shadow beneath white letters.

Add a line of text at the bottom of the

poster. At this point, you would probably

think everything is done, but you could

be half-right or totally wrong. If you want

to use the drawing on the Web, then

you’re half-right. To be 100% right, choose

File>Export, and select JPG, or PNG from

the list of file types. You can import the

resulting file into Fireworks for any type of

slicing or special effects you want to use. 

On the other hand, if you’re going to

print the drawing, you MUST change the

Document Settings>Raster Effects

Settings to 300ppi. Also, check the

Optimal CMYK printing box. If you don’t,

you’ll see hard edges around the smoke

and headlight beam.

Just a reminder: this drawing was

posterized, but CMYK colors were used to

allow for the various raster effects that

were going to be used. Be alert for prob-

lems if you attempt a project like this

with spot colors by printing separations

of small areas of your drawing before you

go full-steam ahead with an illustration. 

I

llustrator, designer, author, and Team

Macromedia volunteer Ron Rockwell

lives and works with his wife, Yvonne, in

the Pocono Mountains of Pennsylvania.

He is the author of FreeHand 10 f/x &

Design, and co-authored the Studio MX

Bible. He has just introduced a “Casual

FreeHand” course available at

www.brainstormer.org. Many thanks to

John Nosal, Peter Moody, Bob Sander-

Cederlof and other engineers at

Macromedia for the technical editing and

support they provide. guru@brain-

stormer.org
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8-LINE
RIA DATA SOURCE

THE

IN THE FIRST ARTICLE IN THIS SERIES 

(MXDJ, VOL. 2, ISSUE 10) I MADE 

THE CASE FOR THE RICH INTERNET 

APPLICATION (RIA) AND DISCUSSED 

THE ADVANTAGES OF THE FLASH 

CLIENT. LAST MONTH WE EXAMINED 

THE CONSTRUCTION OF AN XML- 

DRIVEN RIA BUILT USING FLASH S DATA 

AND UI COMPONENTS. THIS MONTH 

WE LOOK AT HOW COLDFUSION 

PROVIDES A SIMPLE BUT POWERFUL 

WAY TO MAKE DATA AVAILABLE AS 

BOTH A WEB SERVICE AND A FLASH 

REMOTING DATA SOURCE. 

by art phillips
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Data can be made available via Web

services using several technologies,

including ColdFusion. Data exposed

through a Web service can be used by

both Flash and non-Flash clients. If your

Web service represents data using stan-

dard data types such as arrays and

objects (or structures in ColdFusion), the

data can be used in other technologies

such as ASP.NET, PHP, or Java. Web servic-

es obtain this flexibility by using a stan-

dardized method of describing and

exchanging data and commands. The

exchange is formatted using an XML

schema called SOAP, the Simple Object

Access Protocol. This flexibility is gained

at the expense of some efficiency. An

exchange of data and commands

between a specific server technology and

a specific client can be optimized for that

specific client/server technology. This is

the benefit of Flash Remoting.

Flash Remoting data sources, such as

Web services, can be produced by several

technologies, including ASP.Net, PHP,

Java, and our favorite server application

technology, ColdFusion. Flash Remoting

exchanges commands and data with the

Flash client using a binary format called

AMF, the Action Message Format. This

binary exchange is more efficient than

the text-based XML structure of SOAP.

Flash Remoting data sources provide the

most efficient means of communication

between the Flash client and the server.

There is an important issue regarding

data types that developers should make

note of. The results of a ColdFusion query

in their native form may not be usable in

other frameworks. Also, the results from

queries in other technologies such as

ASP.NET may not be usable in Flash.

We conceptualize and work with data

from a query as an array of objects in

Flash. Each record is an object and the
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record’s fields become the object’s prop-

erties. The records/objects are then

stored in an array. 

However, in its native format data

returned by a query may not be usable

across different frameworks. The exact

structure of the data returned by a query

will be specific to the server technology

that created it. It will not be a simple

array of objects. This may prevent the

data from being used in other technolo-

gies.

To achieve interoperability across

server technologies, developers should

parse database results into a generic

array of objects (or in ColdFusion, an

array of structures.) This data structure

will then be able to be used by clients

built in other frameworks.

The good news is, when you work

with a ColdFusion data source and a

Flash client, the results of a database

query may easily be passed directly from

the server to Flash. While clients written

in other technologies may not be able to

use this data source, it will work fine with

the Flash client. This represents both the

easiest and most efficient way of passing

database information from ColdFusion to

Flash via both Web services and remot-

ing. 

The focus of this article is on a

ColdFusion data source for a Flash client.

The ColdFusion data source that we will

examine here will be designed to pass

the results of a ColdFusion query directly

to a Flash client. Readers who wish to use

a ColdFusion data source for other clients

should be prepared to parse the CF query

into a generic array of objects. 

ColdFusion Components (CFCs) repre-

sent ColdFusion’s entry into object-ori-

ented programming. CFCs provide the

power of object-oriented development

while maintaining the classic friendliness

of ColdFusion. CFCs provide a familiar

tag-based development model that

leverages the power of the JRun J2EE

engine that lies at the heart of the

ColdFusion MX server.

CFCs are a collection of one or more

ColdFusion functions. The CFC itself can

have values associated with it. Those of

you reading this who are familiar with

object-oriented programming (OOP) may

recognize what we have here – a Class.

A Class is a collection of methods

(functions) and properties (values). A CFC

is a collection of functions and values.

CFCs are Class files they are ColdFusion’s

object-oriented building blocks. CFCs

become Java classes on the server offer-

ing the power of Java and the ease of

ColdFusion.

Dreamweaver is the current develop-

ment tool for ColdFusion applications,

and does a real fine job. (I hear the

groans and sneers from you ColdFusion

Studio users. <grin />) Anyway,

Dreamweaver is the development tool

we’ll be using here. It will provide us with

a starter file we can modify to create our

data source.

From Dreamweaver’s new file dia-

logue choose ColdFusion Component

from the Dynamic Pages Category (see

Figure 1). Dreamweaver creates a new

document with a generic skeleton of the

key elements of a CFC.

For this example, the file will be saved

as flashDataSource.cfc into a directory

called myCFC in the web root of the serv-

er. Note the .cfc extension instead of the

traditional .cfm. Now let’s examine the

flashDataSource.cfc.

The outer <cfcomponent></cfcom-

ponent> declares the ColdFusion compo-

nent. It is comparable to the class decla-

ration in Java and ActionScript 2.0. A

cfcomponent tag contains one or more

user defined functions (UDFs), or what

most developers would just call func-

tions. Dreamweaver has provided an

example of a UDF in our CFC.

While they work the same as func-

tions developers may be familiar with

from other languages, ColdFusion’s UDFs

are constructed very differently. UDFs fol-

low ColdFusion's tag-based syntax. This

can easily be seen in the opening cffunc-

tion tag in line 2 of Figure 2. 

The name of the function is declared

in the name attribute of the cffunction

tag. The data type of the return from the

function is also an attribute; returntype. A

bit strange compared to other languages,

but not difficult to understand.

The most interesting attribute of the

cffunction tag is the access attribute. This

is the magic key to creating a Web service
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and Flash Remoting datasource from a

CFC. 

The access attribute accepts four val-

ues: private, package, public, and remote.

These values determine from where and

how the function may be accessed. 

An access value of private is the most

restrictive. It allows only other functions

in the same CFC to use the function.

An access value of package allows

any other CFC in the same directory to

use the function. Here the Java under-

neath the CFC shows itself. A directory of

Classes is called a package in Java.

A public access value means that any

CFC anywhere on our server can use it.

An access value of remote means that

clients outside of our server can use our

function as either a Web service or a

Flash Remoting data source. The

ColdFusion server takes care of the trans-

lation of all requests and results to and

from the appropriate format: SOAP or

AMF. The ColdFusion server can even pro-

duce the metadata that clients need to

help consume our Web service, the WSDL

file (Web Service Description Language).

More on WSDLs later.

After the opening cffunction tag we

encounter a cfargument tag in line 3.

While a traditional function would pass

its arguments as a list in the function dec-

laration's parenthesis, ColdFusion uses

separate cfargument tags to pass values

to the cffunction. 

Notice the attributes for the argu-

ment name as well as for data typing and

making the argument required. Unlike

typical ColdFusion, which is loosely

typed, CFCs provide strong data typing

similar to ActionScript 2.0 and Java.

Line 4 shows us how to set a variable

in the function and line 5 shows us how

to return it from the function. 

There is more code here than we

need for our data source. We won’t need

any variables in our function and we will

not need any arguments, so we can

delete lines 3 and 4. Now we will start

modifying the cffunction.

The function should have a descrip-

tive name. Since our data source will pro-

vide the client with product data we will

name our cffunction getAllProducts.

The most important attribute for our

data source is the access attribute.

Setting the access attribute to remote

makes this function available as both a

Web service and Flash Remoting data

source.

The returntype of the function is set

to query. We are going to pass the result

of our database query straight to Flash.

We still need to modify the return state-

ment but that can wait until we add the

query to our function.

Our data source is called products-

DSN. The result of the cfquery will be

called qProducts, and the query will pull

all information from a table called

Products. The cfquery will look like Figure

3.

The cfreturn line can now be modi-

fied to return our query: qProducts.

The final CFC will have only eight

lines of code (see Figure 4).

We now have the data source we will

use in future articles. For those of you

who can’t wait and want to start using

our data source, be aware of one impor-

tant issue. The ColdFusion server installs

with Flash access to Web services and

remoting turned off. The FlashGateway

must be enabled for our CFC to work as a

Flash data source. How the FlashGateway

is turned on varies with the version of

ColdFusion you are running. See

Macromedia’s ColdFusion TechNote

#18608 for details.

That’s it for this month. Next month

we use our data source to feed data to

Flash as a Web service and from there we

move on to remoting. See you then! 

Arthur Phillips has been delivering cut-

ting edge training solutions since 1984

and has developed instructional materi-

als for George Washington University,

the Federal Reserve Board, the U.S.

Graduate School, and many others. Art

has an extensive background in video,

multimedia. electronic graphics, Web

development, and e-Learning. He holds

too many certifications as a Macromedia

Instructor, Designer, and Developer to

list. His Web site (www.artswebsite.com)

is a well-known resource in the

Macromedia community. 

art@artswebsite.com
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ello! I wanted to wait and for-

mally greet you from the

Macromedia MAX Conference

in New Orleans. Some of you

might know me from my writing at

Director-Online, or from the Macromedia

DevNet Center. Others are probably read-

ing this and saying to themselves “Hey…

wait a minute… where’s James…” In any

event, I wanted to report on the confer-

ence, give you a taste of what happened

in case you weren’t there, and finish up

by talking a little about what I’d like to

see as the new editor of this section.

The MAX crowd this year was a split

crew: there were a lot of Flash develop-

ers, a surprising number of Director

developers, and several folks from the

educational community working with

Dreamweaver and Fireworks. Then there

was the ColdFusion server crew, and they

bring with them a slightly different set of

issues that many client-side developers

just don’t have to consider. So the entire

conference struck me as a little bit polar,

although the crossovers between these

groups were interesting.

I spent most of the conference hang-

ing around with Tom Higgins, technical

product manager for Director; and Emmy

Huang, product manager for Shockwave.

In addition, Mark Jonkman, Richard Ross,

Brian Robbins (of www.cow-

boysandengines.com fame), Darrel Plant

(of Director-Online), Kristen Banham from

IntegrationNewMedia (www.integra-

tionnewmedia.com) and a whole slew of

well-known Director developers was

there and we all went out and had a

night on the town. INM and Macromedia

even threw a Director user’s party on

Tuesday night.

So with all that going on, the question

I had to respond to over and over again

was the infamous, “Is Director dead?” I’m

not sure where this comes from; I’ve been

hearing of Director’s demise since version

7. Nonetheless, let me be the first to say,

“No, it’s not dead.” Some feedback I got

on Charles’ editorial in the November

issue (Vol. 2, issue 11) showed me that a

lot of people saw his love of Flash and

assumed we wouldn’t be covering

Director anymore. Nothing could be fur-

ther from the truth. Others kept asking

me if Macromedia is actively developing a

new version: without getting myself in

trouble, I can safely say that “Yes, there is

active development on a next version of

Director, with significant feature addition

and/or modification.” Some folks were

offended by the fact that Director wasn’t

mentioned in the keynote for the confer-

ence: well, there were actually a lot of

products not mentioned in the keynote.

The major event of the conference

seemed to be the new ColdFusion

(Blackstone) and its integration with the

new Flex 1.5, so most of the big public

speeches revolved around that. I was

excited to see Tom and Emmy taking the

conference very seriously, talking to their

developers, making sure they know the

customers. That’s our old friend

Macromedia!

The sessions were excellent this year.

Brian Robbins gave a talk on developing

3D game engines in Director, and if you

haven’t seen his stuff you really should.

He talked about several techniques for

“light mapping” a scene to pre-generate

shadows (something we will be covering

in future articles here), doing some colli-

sion detection based on facing surface

normals, and about his experiences with

the art team on Cowboys & Engines.

Mark Jonkman taught us all about using

Flash inside of Director, several reasons

why this approach has some appeal (like

exceeding Director’s 1,000-sprite limit),

and several ways for Director and Flash to

communicate. Tom Higgins gave us a talk

on using JS syntax in Director, including

how to use some object-oriented pro-

gramming techniques. He then went on

to describe some of the pitfalls of this

feature in its current implementation

(which are, in his mind, “version 1 grow-

ing pains”). He hinted that Macromedia is

at least considering an ECMAScript 4

style implementation, which would be

very similar to ActionScript 2.0 in Flash. I

certainly hope it’s more than a hint! I

unfortunately didn’t get to attend

Richard Ross’ seminar on creating

enhanced DVD content, but I heard good

things about it.

In spite of the sessions, MAX was not

without its letdowns. The biggest of

these was the “Sneaks” session, in which

we were supposed to get sneak previews

of what’s coming. Well, that sort of hap-

pened. There were no sneaks of Director

this time. There were a few sneaks of

Flash, which were neat to see. Most of

the time, however, was spent on looking

at Flex 1.5, which was released during the

conference. If it is released, then it is hard-

ly an alpha; clearly it has been refined

and polished. It didn’t do justice to the

“sneaks” that Macromedia usually hands

out. Kudos to the ColdFusion Develop-

ment Team, which tried to show us some-

thing really new but wound up with a

Blue Screen of Death. I respect that more

than canned, prefabricated demos in a

session that is supposed to be beyond

the cutting edge.

To summarize MAX, the food was

excellent, the beer was pretty good, and I

had a wonderful time talking to

Macromedia about all things Director,

and talking to Director developers from

all over the world. In talking with all

these folks, I got some great feedback on

MXDJ and some ideas for the section. In

a nutshell, here is where I would like to

see us go:

future

Greetings, Faith, Reviews, 
and Seafood

A new editor gets direction from MAX
by andy phelps

h
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• Higher-end content. This is not to say

we won’t focus on the beginning stuff

anymore, we will, but there are also a

lot of developers out there clamoring

for more in-depth coverage of various

issues, and I want to provide resources

to them as well. I want to provide a

true balance of coverage for beginners

through experts.

• Games and 3D coverage. It seems a lot

of Shockwave developers are making

their living doing games or interactive

simulations, and resources in this area

are particularly scarce.

• JavaScript syntax. This hasn’t gotten a

lot of press anywhere yet because

most developers still aren’t using it.

But there are a couple of reasons to

start using it in conjunction with Lingo,

rather than a replacement. Under the

old programmer’s motto of “use the

right tool for the job,” we’ll be explor-

ing the JS syntax as a tool for specific

tasks. If Macromedia is really looking at

an ECMAScript 4 implementation, this

could be very powerful for potential

new users of Director as well.

• Integration. More and more develop-

ers are using Director in conjunction

with other products in application con-

struction. From Flash to Photoshop to

Xtra building, integration is always an

issue, and sometimes the edges are a

little sharp. Timely focus on working

with content and tools that relate to

Director is as important as Director

itself, and it is an area that is not cov-

ered well in any of the documentation.

• Case Studies. Has your company just fin-

ished a really cool project using Director

(or Director and a slew of other prod-

ucts)? Would the community learn some-

thing by looking at the way you did it, or

the concept of what you designed?

These aren’t advertising pieces for self-

promotion, but a good case study can

teach the community a lot about what

other folks are doing and what develop-

ment practices are in place that you

might want to adopt. I’d like to see a

handful of good case studies each year, I

think it could prove an invaluable asset.

In addition to the above, this column

will continue to offer timely information

for Director users at all levels, as well as

information on integrating Director with

other products and solutions. If there is a

particular topic on which you want to see

coverage, if you think you would like to

write an article, or if you think the thing

you just shipped would make the perfect

case study, then let me know! Charles

had one thing exactly right in his editorial

last month: this is your magazine, and by

extension this is your section. It exists to

serve you, the Director user. I’d like to

thank SYS-CON for inviting me aboard,

and to say how wonderful it was to meet

all of you at MAX. To contact me at any

time, just send me an e-mail at

amp@it.rit.edu. 
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coursework in multimedia programming,

game programming, and simulation/visu-
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This technique is commonly used, for

example, to make sure that skyboxes

draw before any other objects in the

scene, or to ensure that the Heads-

Up Display that features the player

controls are always drawn “on

top of” any of the other ele-

ments in the scene. In this

article, we will explore

using multiple cameras

that are linked

together through a

management

structure in

such a way as

to give

back to

the

Lingo develop-

er what is missing

in Shockwave3D: semi-

direct scenegraph manipu-

lation. The authors have suc-

cessfully used this technique in a

game development project entitled

“Broadsword,” and all demo code is taken

from that source tree. The technique,

however, is extractable to any

Shockwave3D environment, and can be

used regardless of subject matter. For

example, Brian Robbins presented on this

technique and its use in his own work at

Macromedia MAX.

To begin, it is often a good idea to

review what we know about how the

computer renders a 3D scene. Objects are

made up of triangles, which are rendered

onto a two-dimensional image plane by

projection from the viewer (i.e. the cam-

era in the scene). As triangles are ren-

dered on to the plane, two pieces of

information are stored per pixel. First, the

color of the pixel is stored, based on sev-

eral calculations in 3D space such as tex-

ture, material, lighting, etc. Second, a

depth value is stored per-pixel, which

represents the depth of that pixel from

the viewer. The collection of all of the

depth-values for the 2D image that the

scene is projected onto is called the

depth buffer, which is simply a memory

area in which the depth value for each

pixel is stored. When a second triangle is

drawn to the scene, as it renders its pixels

onto the plane it looks at the depth infor-

mation of the pixels it would be writing

to. If the pixel that would be written is

closer to the viewer than the pixel

already stored, then the new pixel is writ-

ten. If it isn’t, then no change is made.

This is how 3D determines that one trian-

gle is “behind” or “in front of” another tri-

angle. After all of the triangles in the

viewable scene area (read: “inside the

camera frustum”) have been drawn to the

image, the image is flipped onto the

screen.

But imagine that you could, whenever

desirable, clear the depth buffer, and by

that we mean to reset all the values in it to

a default value. The next time something

was drawn to the screen, it would have no

existing depth information, and so it would

be either completely behind or completely

in front of the existing information. In a true

game-like environment, this is how skybox-

es and overlays are drawn. Unfortunately, in

S3D we don’t have a way of clearing the

depth buffer directly (this is not entirely

true, there are some workarounds using

the unsupported #frontNoDepth flag.

There is, however, a solution. Each

camera in the scene, because it projects

any objects that are its children inde-

pendently of other cameras in the scene,

does not share its depth information with

any other camera. Thus, if there are two

cameras, camera A and camera B, and A

draws before B, when B renders triangles

onto the buffer it cannot read from the

depth buffer of A. The benefit of this is

that any object projected through cam-

era B will draw on top of any objects pro-

jected through camera A, regardless of

their actual positions in 3D space. And

with that, we can now explore a system

that allows us to assign order to specific

sets of objects, based on which camera

they are seen through.

For ease of use, we term each set of

objects grouped with its own camera as a

“render group,” because it is drawn sepa-

rately from its peers. Render groups are

drawn in the order they are initially creat-

ed, but objects can be added or deleted

from a specific group at any time. To

begin, we create the initial camera for the

entire scene by calling ghCameraStartup

(see Listing 1), and create an initial set of

render groups by calling ghSetup-

RenderGroups (see Listing 2).

In Listing 2 we identify five render

groups – Ground, Weapons, Objects,

Explosions, and Windows –which are

always drawn in that order, back to front.

Thus, the ground is always behind all

objects in the scene, and any Windows,

which we use instead of Lingo overlays,

are always on top).

The ghSetupRenderGroups handler is

really just a call to establish a render

group manager (see Listing 3), which in

turn is merely a collection of actual ren-

der group objects. Our manager is simply

a glorified property list, and developers

should feel free to use a base properly list

if that is their preference. The only caveat

is that you cannot sort the list to deter-

mine draw order: the reason the render

group created first renders before the

render group that is created second is

because the first camera is before the

second in the list of cameras in the 3D

cast member. That is the order that deter-

mines which camera draws when, not the

property list of Lingo objects.

The real “meat” of a render group is in

the render group object, which is an

object that creates a new camera, parents

itself directly to the main scene camera

that is set up in the script in Listing 4, and

then provides mechanisms for any

object, light, or group in the scene to be

added or removed from that render

group. The entire script of the render

group object is presented in Listing 4,

with comments immediately afterward.

Clearly, a good 90% of that script is

repetitive structure for adding and

removing (or more formally “parenting

and un-parenting”) lights, models, and

groups. There are some interesting issues

to be noted in the new handler, however,

where actual setup takes place. First, we

create a new camera by cloning the exit-

ing scene camera. However, once we par-

ent a first render group to the main cam-

era, we cannot clone it a second time, or

we would not only copy the original cam-

era, but also the child. Thus we always

copy the last camera created, or the low-

est child on the tree. 

Second, because more than one cam-

era will be rendering, we turn off their

clearColorBuffer property, ensuring that



52 • MXDJ.COM 12 • 2004

no single render group can clear any of

the others. The only camera in the entire

scene that should be clearing the color

buffer is the main scene camera. Finally,

we create a group to hold all of the lights

and objects for this render group.

NOTE: When we began using this tech-

nique, we were surprised that all of our

objects rendered solid black. This is

because each camera needs its own

lights. This was originally thought of as a

drawback to the system; however, we

have since used this to great effect, hav-

ing lights in the scene that affect some

objects and not others, and have come to

rely on this technique in several of our

Shockwave3D worlds.

With all of that setup work in place,

objects are created as per any other 3D

world, through primitive shapes such as

#sphere and #box, imported from 3dsMAX

or a similar program, or built from scratch

with the newMesh() call. Regardless of

how an object is built, the final step in

adding it to the world now looks like

Listing 5.

This technique has been invaluable. It

has allowed us to construct our own

overlays by texturing two camera-orient-

ed triangles. It has allowed us to control

draw order regardless of 3D position, and

to effectively layer different elements in a

scene. Finally, it has been a useful tool in

“sky-boxing” several worlds and ensuring

that the size of the skybox has nothing to

do with the size of the world.

NOTE: By setting a camera for a spe-

cific group to orthographic projection

mode (#ortho) and positioning its rect to

the rect of the 3D sprite, there is a 1:1

relationship between screen-space and

world-space along the x/z plane. (Also

note that in fact these coordinates are off

by exactly 0.5 pixels when using the

DirectX renderer, because of a bug in the

underlying library).

As a final example, Figure 1 shows two

examples of Broadsword running in tech-

demo mode, with notations about cam-

era groups and render order. We believe

that this technique should prove useful in

a wide variety of situations commonly

encountered in Shockwave3D, and

encourage developers to build for them-

selves their own grouping systems to take

more complete control of the scenegraph.
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global D3D_WORLD

on ghCameraStartup

vPos = vector(0,0,0) --default lookAt position

vUp =  vector(0,1,0) --default up vector

D3D_WORLD[#g_3DWorld] = member("WORLD")  -- castmember

of the WORLD

--default camera

D3D_WORLD[#g_Camera] = D3D_WORLD[#g_3DWorld].camera(1) 

--set initial position

D3D_WORLD[#g_3DWorld].cameraPosition = vector(0,0,1000) 

--look at the default lookAt position

D3D_WORLD[#g_Camera].pointAt(vPos, vUp)

--rotate up to stare 'down' at our game world

D3D_WORLD[#g_Camera].rotate(-90,0,0,#world)

--make global camera ortho

--(render groups can be either ortho or perspective,

not to worry)

D3D_WORLD[#g_Camera].projection = #orthographic

D3D_WORLD[#g_Camera].orthoHeight =

(D3D_WORLD[#g_iWorldHeight])

D3D_WORLD[#g_Camera].rect =

rect(0,0,D3D_WORLD[#g_iWorldWidth], \

D3D_WORLD[#g_iWorldHeight])  

end ghCameraStartup

Listing 2: Calls to set up initial render groups 

on ghSetupRenderGroups

--setup a manager for Render Groups

D3D_WORLD[#g_oRenderGroupMgr] =

script("RENDER_GROUP_MGR").new()

--create the basic render groups

D3D_WORLD[#g_oRenderGroupMgr].mAddRenderGroup("GROUND"

)

D3D_WORLD[#g_oRenderGroupMgr].mAddRenderGroup("WEAPONS"

)

D3D_WORLD[#g_oRenderGroupMgr].mAddRenderGroup("OBJECTS"

)

D3D_WORLD[#g_oRenderGroupMgr].mAddRenderGroup("EXPLO-

SIONS")

D3D_WORLD[#g_oRenderGroupMgr].mAddRenderGroup("WINDOWS"

)

--explicitly set the window camera to ortho

D3D_WORLD[#g_oRenderGroupMgr].mGetRenderGroup("WIN-

DOWS").mToggleCameraOrtho(TRUE)

end ghSetupRenderGroups

Listing 3: Render Group Manager (a glorified property

list)

property p_plRenderGroups

--create a new render group manager

--and store a propList of render groups to manage

on new me

p_plRenderGroups = [:]

return me

end new

on mAddRenderGroup me, a_sName  

--create render group and add it to internal list

oRenderGrp = script("RENDER_GROUP").new("RG_" & a_sName)

p_plRenderGroups.addProp(a_sName, oRenderGrp)

end mAddRenderGroup me

--get a specific render group by name from the manager

on mGetRenderGroup me, a_sName

return p_plRenderGroups.getProp(a_sName)

end mGetRenderGroup

Listing 4: The Render Group object

-------------------------------------------------------

--  RENDER_GROUP

----------------------------------------------------------

-----------

global D3D_WORLD

property p_sName

property p_camCamera

property p_grpRenderGroup

on new me, a_sName

p_sName = a_sName

--make the render group

p_grpRenderGroup =

D3D_WORLD[#g_3DWorld].newGroup(p_sName)

--void its parent

p_grpRenderGroup.parent = void

--create a camera

--we clone the main scene camera if it has no children,

--otherwise we clone the last child.  We have to avoid

--cloning a camera that already has children.

if D3D_WORLD[#g_Camera].child.count = 0 then

p_camCamera = D3D_WORLD[#g_Camera].clone(p_sName &

"_cam")

else

p_camCamera =

D3D_WORLD[#g_Camera].child[D3D_WORLD[#g_Camera \

].child.count].clone(p_sName & "_cam")

end if

--don't let them clear each other's color buffers

p_camCamera.colorBuffer.clearAtRender = FALSE
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--group camera with the renderGroup

p_camCamera.rootNode = p_grpRenderGroup

iCurNumRenderGroups =

D3D_WORLD[#g_3DWorld].cameraCount()

--add camera to the world

D3D_WORLD[#g_sprWorldSprite].addCamera(p_camCamera,

iCurNumRenderGroups+1)

D3D_WORLD[#g_sprWorldSprite].camera(2).rect = rect( \

0,0, D3D_WORLD[#g_iWorldWidth ],

D3D_WORLD[#g_iWorldHeight])

--link camera to the "real" one

p_camCamera.parent = D3D_WORLD[#g_Camera]

p_camCamera.transform = transform()

return me

end new

on mToggleCameraOrtho me, a_bIsOrtho

if a_bIsOrtho then

--setup for orthographic projection

p_camCamera.projection = #orthographic

p_camCamera.orthoHeight =

(D3D_WORLD[#g_iWorldHeight])

p_camCamera.rect = rect(0,0,D3D_WORLD[#g_iWorldWidth

], \

D3D_WORLD[#g_iWorldHeight])

else

--setup for "real 3D" projection

p_camCamera.projection = #perspective

p_camCamera.rect = rect(0,0,D3D_WORLD[#g_iWorldWidth

], \

D3D_WORLD[#g_iWorldHeight])

end if

end mToggleCameraOrtho

--add a light to this render group

on mAddLight me, a_ltLight

a_ltLight.parent = p_grpRenderGroup

end mAddLight

--remove a light from this render group

on mSubLight me, a_ltLight

a_ltLight.parent = void

end mSubLight

--add a light to this render group by name

on mAddLightByName me, a_sLightName

D3D_WORLD[#g_3DWorld].light(a_sLightName).parent =

p_grpRenderGroup

end mAddLight

--remove a light from this render group by name

on mSubLightByName me, a_sLightName

D3D_WORLD[#g_3DWorld].light(a_sLightName).parent = void

end mSubLightByName

--add a model to this render group by name

on mAddModelByName me, a_sModelName

D3D_WORLD[#g_3DWorld].model(a_sModelName).parent =

p_grpRenderGroup

end mAddModelByName

--remove a model from this render group by name

on mSubModelByName me, a_sModelName

D3D_WORLD[#g_3DWorld].model(a_sModelName).parent = void

end mSubModelByName

--add a model to this render group

on mAddModel me, a_mModel

a_mModel.parent = p_grpRenderGroup

end mAddModel

--remove a model from this render group

on mSubModel me, a_mModel

a_mModel.parent = void

end mSubModel

--add a group to this render group by name

on mAddGroupByName me, a_sGroupName

D3D_WORLD[#g_3DWorld].group(a_sGroupName).parent =

p_grpRenderGroup

end mAddGroup

--remove a group from this render group by name

on mSubGroupByName me, a_sGroupName

D3D_WORLD[#g_3DWorld].group(a_sGroupName).parent = void

end mSubGroup

--add a group to this render group

on mAddGroup me, a_grpGroup

a_grpGroup.parent = p_grpRenderGroup

end mAddGroup

--remove a group from this render group

on mSubGroup me, a_grpGroup

a_grpGroup.parent = void

end mSubGroup

--get a handle to the camera for this render group

on mGetCamera me

return p_camCamera

end mGetCamera

Listing 5

--create a model resource

mrSphere =

D3D_WORLD[#g_3DWorld].newModelResource("SphereMR01",

#sphere)

--create a model

mSphere = D3D_WORLD[#g_3DWorld].newModel("SphereM01",

mrSphere)

--add the model to a specific render group created in

ghSetupRenderGroups

D3D_WORLD[#g_oRenderGroupMgr].mGetRenderGroup("GROUND").mA

ddModel(mSphere)
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hen I created this site to showcase

my illustration work I wanted to

attempt something new. My main

goal was to convey the spirit of my illustrations

without simply imitating them. Borrowing visual

elements from 19th-century circus posters, I cre-

ated my own sideshow. This seemed fitting

because I view my own illustration work as fun

and just a little creepy. To finish the look I used

animated curtain movement and unrolling of the

side posters to help make the site a more

dynamic experience for the viewer. www.hillumi-

nation.com
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